How to test Mender 2.0.0 in Existing Sumo?


I have a Sumo branch with Mender 1.7.0 which is using for testing the Mender standalone mode.
Now, I want to test the update module which is part of the Mender 2.0.0.

Could you please let me know how to upgrade to Mender 2.0.0 (to test the update module with Mender standalone) without changing the existing Sumo base (which have many board specific changes)?

Whether removing the meta-mender sources and adding it again as git clone -b sumo git:// will fetch the latest base with update module support?

What could be the easiest method? :thinking:

Our normal workflow is to first update the latest stable branch with any updates, that means meta-mender/thud and overtime we try to backport to older branches e.g sumo and rocko. This is done “best effort wise” and timing could depend on many factors.

There is currently a PR to update meta-mender/sumo to include the beta release recipes, but this has not yet been merged.

You can take a look here,

The is also one PR for rocko,

Please note that you need to add the following to e.g local.conf to enable the beta components,

PREFERRED_VERSION_pn-mender = "2.0.%"
PREFERRED_VERSION_pn-mender-artifact = "3.0.%"
PREFERRED_VERSION_pn-mender-artifact-native = "3.0.%"
1 Like

The below entries can be applied to my sumo source only after the mentioned PR got merged into the sumo master branch and fetched into my sources right? Please correct me if I’m wrong.

PREFERRED_VERSION_pn-mender = "2.0.%"
PREFERRED_VERSION_pn-mender-artifact = "3.0.%"
PREFERRED_VERSION_pn-mender-artifact-native = "3.0.%"

This is correct.

1 Like

I can see that, all checks have passed and changes are approved for Sumo (from the mentioned PR for sumo).

Hopefully, it will be merged soon for testing :slight_smile:

It has been merged :slight_smile:

1 Like

The sumo-v2019.04 and rocko-v2019-04 releases are now completed. You can find the complete Changelogs here:

for sumo:

and for rocko:

1 Like

Thank you @mirzak and @lluiscampos for the support.

I have fetched the source and added the entries to conf file as @mirzak suggested to take the beta components.

I got the below error while bitbaking the sumo source:

| #
| …/…/…/…/…/…/…/build/src/ fatal error: lzma.h: No such file or directory
| compilation terminated.

After couple of search and debugging, I found that this issue is already addressed by @mirzak in PR but, it is missing in the sumo branch.

After adding the DEPENDS += "xz" in "meta-mender-core/recipes-mender/mender-artifact/", this error got resolved and it build successfully.

I think it is better to add the above changes in the sumo :slight_smile:

Thank you @ajithpv for reporting! I will get it fixed in both sumo and rocko

1 Like

@lluiscampos for Sumo, I have a PR :+1:
For Rocko, I didn’t tested but, I feel this is required :slight_smile:

I am having a different problem now, my build gets stuck in fetch because the old branches have been removed. I think it works for you because you had it already downloaded.

This is my error:

ERROR: mender-2.0.0b1-r0 do_fetch: Fetcher failure: Unable to find revision 040a234aba2abb1b8d9351674892a1b0c7202fea in branch update_modules even from upstream
ERROR: mender-2.0.0b1-r0 do_fetch: Fetcher failure for URL: 'git://;protocol=https;branch=update_modules'. Unable to fetch URL from any source.

So I will be fixing this in addition to the change on your PR.

And I bet it doesn’t work in thud nor in master right now. I working on it

You probably need to remove branch and instead add nobranch=1, as the SHA1 is a tag and the branch has been removed.

I simply remove the meta-mender folder from sources and add it agian using git clone -b sumo git:// This worked for me when I tried earlier today.

Yes, but the source is cached in your yocto environment.

If you do bitbake -c clean mender-artifact && bitbake mender-artifact you will see what I mean :slight_smile:

OK, I got your point now :slight_smile:

I have merged your PR now and ported the change to rocko :+1:

1 Like

Got a bit confused by this today. Also getting fatal error: lzma.h: No such file or directory. Is this now resolved in master? and if so can you point me to the commit?

This should also have been solved on sumo,

Are you using Sumo? :thinking: