Yocto Thud release and Mender


#1

Hi,

A few weeks back the Yocto project released Thud (2.6). The update to meta-mender normally takes another few weeks to create and this is now the case.

With above said it is time to start updating the integrations that we have in meta-mender-community and I also the Mender Hub posts. A crucial part of Mender Hub is that the reference implementations and the posts that we have here are continuously updates which ensures a high quality platform.

I have already created the thud branch in meta-mender-community and updated the Raspberry Pi 3 and Asus Tinker Board integrations and posts and will continue working on the boards that I have added.

NOTE that meta-mender/thud by default uses GRUB integration on ARM boards instead of the previous U-boot integration. This still relies on U-boot being present but utilizes the bootefi command which can load and execute GRUB2 as an EFI application, where all the Mender parts are integrated. The bootefi command is something that is part of config_distro_boot_cmd meaning that if your board is utilizing this there is a high likelihood that you do not need any patches to U-boot to integrate Mender.

If there is already an U-boot integration in place or if the GRUB integration does not work for some reason one can disable this new default by adding the following to local.conf, as I have done for Raspberry Pi boards because they have a somewhat “special” boot procedure.

In which case it will fall-back to the “standard” U-boot integration which we have been using up until thud.

Happy updating :smiley:

@eystein @texierp @jorisoffouga @MarekBelisko @dwalkes


#2

Thanks for the update @mirzak

From my side, already planned :wink:

I’m just waiting for the ‘thud’ branch for both meta-atmel and meta-freescale :grinning:


#3

Thank u.
I already created a build with master branch of meta-freescale and it worked. Next week I’ll try to boot the system and follow integration checklist.
However I removed path 007 (if I remember the right number) to be able to build


#4

mmm, no I made a mistake, because I was building without u-boot support, since It’s changed in version 1.7.
Enabling
MENDER_FEATURES_ENABLE_append = " mender-uboot mender-image-sd"
MENDER_FEATURES_DISABLE_append = " mender-grub mender-image-uefi"

I got this error:

Applying patch 0003-Integration-of-Mender-boot-code-into-U-Boot.patch
patching file include/env_default.h
Hunk #1 succeeded at 10 with fuzz 2 (offset 1 line).
Hunk #2 FAILED at 23.
1 out of 2 hunks FAILED – rejects in file include/env_default.h
patching file scripts/Makefile.autoconf
Hunk #1 succeeded at 111 (offset 2 lines).
Patch 0003-Integration-of-Mender-boot-code-into-U-Boot.patch does not apply (enforce with -f)
ERROR: u-boot-imx-2017.03-r0 do_patch: Function failed: patch_do_patch

I’m using u-boot-imx from meta-freescale master branch (because thud branch is still not available).


#5

meta-freescale’s thud branch is finally available https://github.com/Freescale/meta-freescale/tree/thud


#6

Thanks, will add this to my todo list over the holiday break :slight_smile:


#7

@mirzak, the Thud release is working for me with the PR at https://github.com/mendersoftware/meta-mender-community/pull/41


#8

A big thanks to everyone who have updated the integrations and posts. This ensures a platform with high quality working with the latest Yocto releases.