Problems with Raspbian Buster

Hello everyone,
has someone of you been able to make an buster-mender-client?
i mean from a clean image & not from a stretch to dist-upgrade into buster, i was also able to do that but this cant be used as a golden image.
Thanks!

Hi @genedupre!

Do you mean taking a vanilla Raspbian buster .img and running mender-convert on it and make sure the Mender client works in the resulting converted image?

This has indeed been tested, if you look under the “Test results” header. Did you try with latest 1.1.x of mender-convert?

What are the steps you are doing that does not work, is there some logs/output that you could share?

He @eystein

yes, a clean/fresh raspbian buster.img from the rapsbian website, but directly inside the mender-convert does not produce an working .sdimg for me, the artifact on the other hand does work fine.

i’m using

DEVICE_TYPE=“raspberrypi3”
ARTIFACT_NAME=“2019-07-23-raspbian-buster-lite-clean”
RAW_DISK_IMAGE=“input/buster-lite-clean_23-07-2019.img”
MENDER_DISK_IMAGE=“23-07-19_rapbian-buster-lite.sdimg”
IP=“192.168.1.1”

and

./docker-mender-convert from-raw-disk-image --raw-disk-image $RAW_DISK_IMAGE --storage-total-size-mb 7000 --mender-disk-image $MENDER_DISK_IMAGE --device-type $DEVICE_TYPE --artifact-name $ARTIFACT_NAME --bootloader-toolchain arm-buildroot-linux-gnueabihf --demo --demo-host-ip $IP

i did a fresh clone from 1.1.x from the git

as always, thanks!

OK!

Can you elaborate a bit more on what you mean by “not working .sdimg” – how is it not working? Does it not boot at all, and if so, do you see anything during boot (e.g. rainbow screen, console output)?

Hello @eystein

when i make an .sdimg with the commands mentioned above, that .sdimg simply does not start, no rainbow, no 4 raspberries, which probably means its not finding the boot, or working with it

Hi @genedupre,

I tested latest buster (2019-07-10) myself now and I see the same problem. Converted image is at https://mender.s3.amazonaws.com/raspbian-images/2019-07-10-raspbian-buster-lite-mender-boot-issue.zip

I created an issue report at https://tracker.mender.io/browse/MEN-2673

Can you try buster 2019-06-20? It has been reported to work. This direct link (lite image) should work: https://downloads.raspberrypi.org/raspbian_lite/images/raspbian_lite-2019-06-24/2019-06-20-raspbian-buster-lite.zip

hi @eystein
thanks you for the help!
could i ask quickly why ‘some’ busters would work
and why some wont? or even older OS’s like raspbian-jessie for that matter
Has this to do with systemd? or kernels in general?
As always thanks!

quick update: i did the mender-convert on the 2019-06-20 buster-lite with the same commands as above, but with no succes, this time tough, the pi give the rainbow & 4raspberry’s for half a second, for it then to never give any feedback after that.

Now i noticed on the switch, that the buster-pi was getting traffic, after an arp-scan & finding the ip, i could ping the device, so i did a leap of faith & logged into the pi blindly with no terminal feedback to activate ssh, and then ssh’t into the device, the device works perfectly, just no signal on the hdmi, also mender worked like intended.

So all these busters i’ve tried converting @eystein all worked probably, they just where not giving an signal/output to the hdmi.
From my understanding, this will probably mean something whent wrong when mender-convert was creating the uboot for the pi, because i also did the ‘touch ssh’ trick to activate ssh where the uboot resides and the pi also did not activate ssh next time i booted it.

Hi @genedupre,

Thanks for testing!

In general the problematic areas tend to be around the bootloader. For example, RPi uses a proprietary bootloader (which makes it really hard to integrate, as it’s basically a black box) so mender-convert switches to use UBoot. Mender needs to integrate with the bootloader in order to support atomic rollback (it needs to tell the bootloader to boot from the other partition a few times after an update, for example). If just all boards would use a standard bootloader & boot process, everything should be trivial. But even those using UBoot often create a custom fork of it. :frowning:

Thanks for the update, though, I think someone with a bit more knowledge about this area will take a look.

@genedupre, please take a look at the updates in above. If you are able to test out the image have prepared it would be great.

Hello @mirzak
i installed the first & second buster images from https://tracker.mender.io/browse/MEN-2673
the first image, did not give hdmi output, but i also tried

sudo vim /boot/config.txt
#added these lines
hdmi_force_hotplug=1
hdmi_drive=2

and this did also not work, so i assume the problem is still the uboot

the second image ref: https://tracker.mender.io/browse/MEN-2685
i also had a yellow output on one of my stretch pi’s, but was fixed by giving --storage-total-size-mb from 3600 to 7000 on the next convert, on a 7.4 gb sd-card, however this wont be the case here i assume, since there is plenty of space on the image.

greets, gene

I am not sure I follow, did you manage to get rid of the “yellow output”?

Please note that I moved this to a separate topic as it was started to get lengthy under Raspberry Pi 3 Model B/B+ Raspbian

hello @mirzak
yes, i also had the "yellow terminal/output, but with stretch images, this was because i gave it to less space apparently (–storage-total-size-mb 3600 on the convert), but by giving it the full sd-card space (7.4gb) it went away, the problem probably has nothing to do with space it itself. i dont have a clue what caused and fixed the problem, it was just a lucky guess