Password constraints

Hi all,
I created a VM into Azure by using terraform.
I ran a custom script to install a Mender hosted server following the documentation.
I programmatically created a new user with a 8 alphanumeric password without any error.

Anyway when trying to login, the following error is raised
There was a problem logging in. Please check your email and password. If you still have problems, contact an administrator.... [Request ID: 70f752fd]

I wonder if there is any rules about password (allowed characters, min/max size, …).

I would like also to know how resetting the password of the existing user.

Many thanks for your help,

Best regards,

@peter any ideas?

@Fabrice can you please explain how you created the user? You mention you’ve done it “programmatically”, which API end-point did you use? Can you try to create the user entering the useradm container and using the CLI?

hello @Fabrice

thank you for trying Mender.
I would just try to reset the password with:

docker exec -it `docker ps | grep useradm | tail -1 | awk '{print($1);}'` useradm set-password --username your-useranme --password new-password

best regards,

Thank you all for your feedback !

In my Terraform script, I ran ./run exec mender-useradm /usr/bin/useradm create-user --username=<email> --password=<8 alphanumeric character password>

I will try Peter’s answer and get back to you.

Have a nice WE,


Hi all,

Thanks a lot to Peter who has solved my problem.

I added 2 non alphanumeric characters to have 10 character long password.

Have a really nice WE,


feel free to reach anytime! have a good day!