There is a problem while logging in

I did the installation of mender server with docker compose, and successfully see the ui, but there is a problem while logging in.
I created the account with the following command;
./run exec mender-useradm /usr/bin/useradm create-user --password=mypass123.*
But, I cannot login.It gives the error message saying that “There was a a problem logging in.Please check your email and password. If you still have problems, contact an administrator.”

Thanks in advance

Also, I am sharing the output of docker ps here:

As you see, some of the services are restarting. I don’t know why it is so because I have followed the server installation with docker compose documentation. The only change that I have made is to use port 44344 instead of 443. All the remainings are the same.

Also, I am sharing logs of the useradm services.

Any HELP ?

Hello @dekan , the issue seems to be in the MongoDB. Can you please share your mongodb container logs?


1 Like

Thanks for replying.
Here is the mongodb container logs:

Is this a fresh install or an upgrade? The MongoDB log

“Failed to start up WiredTiger under any compatibility version. This may be due to an unsupported upgrade or downgrade.”

is usually related to an unsuccessful upgrade with a version gap.

If it’s a fresh install, can you please try the 3.6 version, which is the latest LTS? Evaluation with Docker Compose | Mender documentation

You should fully recreate your storage layer (warning: this destroy your MongoDB data, please backup any important data before):

docker volume rm mender-db
1 Like

This is a fresh installation, but I have tried a version 2.4 before on the same server.Then, I deleted the mender-server directory and related images, then after some time, I started to install version 3.4.

Does this problem occur because of that ?

That should be it: your mender-db volume was for the older MongoDB version used in the 2.4 version. Then you tried the 3.4 version with MongoDB 4.4, but the older MongoDB data was still in the mender-db docker volume, hence the upgrade issue.

Please remove the docker volume and retry the fresh install


Thank you very much.
It is solved now.

Have a nice day.