Mender 2.5.0 Problems with Filters, Hostnames and More

Hi Mender Folks,

We just upgraded our Mender server from 2.4.0 to 2.5.0 after making the necessary undocumented manual mongodb upgrades. In the web GUI, we’re finding that the filters in All Devices aren’t working for hostname and hostname is not being displayed when it is selected as the Default device identity attribute. Since we use hostname to identify devices in the field, this problem has rendered the mender GUI in 2.5.0 almost useless for our needs. We’re going to have to revert to 2.4.0 so that we can find our devices.

Additionally, we noticed the unassigned group is in static at the very end of the devices list. This seems like an unintuitive location for it.

Hi @ckelloug2,

thanks for using Mender and I’m sorry to hear 2.5.0 is causing issues for you.

Can you please try entering the deviceauth container, e.g. running:

$ docker exec -it <name of your deviceauth container> sh

Then, from the container, you can run:

$ deviceauth propagate-inventory
$ deviceauth propagate-inventory-statuses
$ deviceauth propagate-inventory-id-data

This will sync all inventory, statuses and identity_data attributes from deviceauth to inventory.

Please let us know if it solves your issue.

Regarding the unassigned group, it is only relevant for statically grouped devices, since a device might join a dynamic group any moment. So a list of unassigned devices that takes all groups (static and dynamic) into account might be outdated the second it is sent from the backend. Does this clarify the location a bit? With that in mind, would you consider a different location to be more intuitive?

@mzedel
Sorry for the slow response. We were dealing with some other things.
I have remerged 2.5.0 into our setup and run the commands that you suggested in the deviceauth container.

Default device identity attribute now works in chrome but not firefox 80.0.1. It seems to be some sort of UI bug in the web application.

In Firefox on the devices screen, The default device identity attribute dialog is only showing Device ID and status most of the time and is not showing the option for hostname. I clicked this dialog several times and one time it did show hostname and I selected it. It appeared that hostname was shown as an option after I clicked on one of the devices in the devices menu.

Hostname is showing on the device identity screen only when I click on one of the devices. It then goes away if I click refresh.

With filters on the devices screen, I select a hostname from one of the devices and do filters hostname equals ourhostname and no devices are found even though I selected a hostname that’s known to exist.

Since this works in chrome we’re okay for the moment.

We’ve downgraded back to 2.4.0 after trying the fix from @mzedel Hostnames worked for a while after the fix when using chrome but after a few days they no longer worked. Hopefully this gets fixed soon as we can’t use 2.5.0 if it doesn’t consistently show hostnames.