How to run mender on ubuntu noble

Im having a problem with installing mender on my ubuntu on my orange pi 5 plus ( GitHub - Joshua-Riek/ubuntu-rockchip: Ubuntu 22.04 and 24.04 for Rockchip RK35XX Devices thats system which i use )
Any ideas how can i install mender on such system?

@livelove1987 well, to understand the problem, how did you try in the first place?

Started with pasting device installation script to cmd than tried: Downloads | Mender documentation
And got following error:

Then tried installing from source and chosing debian bookworm but having some issues with authorization ( and still dont know how to add the device to dashboard )

@livelove1987 ok. After installing from source, have you run mender-setup? That should walk you through everything that’s required to add the device to your account. For a somewhat streamlined process, you can also provide the tenant token to mender-setup, as found under the “Organization” bullet of your account.


Let me try this one more time

Did following thinks and nothing is showing in dashboard

Also here are the logs:

I used same tenant-token as one used in connect device command in dashboard

@livelove1987 ok. Basically I actually expect that to work, but given the fact that you’re not using the demo intervals the device won’t check again until in 5 minutes (300 seconds). So as long as you’re busy making thing initially work, I’d go with the shorter demo intervals, you can easily change those later.
More details will be provided by the logs of the mender-authd service, this is the one that actually handles the connection to the backend. In my experience, the device usually shows up as pending shortly after the initial request by mender-auth which yields unauthorised in the logs, e.g. a few minutes.


Even after restarting ( sudo systemctl restart mender-authd ) nothing is showing in the dashboard, here are the mender-authd logs

Oh okay its started working, im realy glad for you help.

1 Like

@livelove1987 glad to hear. Like I said, it usually takes a couple of moments. :+1:

1 Like

A post was split to a new topic: Install latest artifact to group

2 posts were split to a new topic: Device goes into pending state again