Cannot Accept Devices

I was following the get started instructions for a virtual device (, but got an error when trying to accept the device. Do you know what is causing the error?

The error message was (see the screenshot at the bottom):

There was a problem updating the device authorization status: [object Object]

The steps I followed were:

  • Went to the devices page
  • Clicked create a virtual device for now
  • Clicked “Copy to clipboard”
  • Pasted the code into a terminal and press return
  • Went to the pending device list
  • Tried to accept the device

The first time I tried with an older version of docker that was already installed, but I tried again with the latest version and the result was the same.

I also cannot dismiss or reject devices, even after shutting them down.

1 Like

@merlin @tranchitella can either of you help here? I could not replicate this myself using a qemu device.


Hello @gphillips-a2e

thanks for trying Mender.
since we cannot replicate the problem, I would ask you to provide a screenshot of what happens on the web console (e.g.: to access it in Chrome click with the right mouse button somewhere on the page and choose “Inspect”), I would need the screenshot from the “Console” and “Network” tabs as you press “Accept” to accept the device.

best regards,

@gphillips-a2e, just to confirm, are you logged in as the admin user? I could image you can get these type of errors if you are logged in as a read-only user, which does not have permissions to accept devices.

Here are the screenshots:

I cannot find anything in the settings or profile which says whether I am admin user, but someone else created my account so it is possible that I am not. How can I tell?

I talked to the person that created the account. He has given me additional permissions and it is now working.

Thanks for your assistance.

1 Like