Unable to boot raspberry pi 4 using offical image

Hey everyone!

I’m new to mender, just trying it out on a pi I have laying around.

I’ have tried to use the following images unsuccessfully:


I have added wifi settings in wpa_supplicant as advised in the guide but the device does not show on my router via wifi nor if I plug in the ethernet cable.

I have tried booting with HDMI cable in either of the ports.

Uboot output gets displayed on the screen when HDMI is plugged in, but then after it finished nothing happens and screen loses any input defaulting to background screen saver.

I can use other SD card with a different OS without any problems on the same rasbpi.

Are there any other images or debug tips worth trying?

Thanks for help.

What do you mean by the “background screen saver”? Is that from the Raspberry Pi OS? If so then I would see about connecting a USB keyboard and mouse and seeing if you can login. Since both of those images are the “lite” images, they boot just to a console login prompt.

But since you say it doesn’t show with ethernet connected, I doubt that the OS is booting. Just to confirm, you are using a Raspberry Pi 4 device right?

I should have been more clear, “background screen saver” just means that whatever the screen manufacturer choses to show in the absence of signals.

Yes it is raspberry pi 4 B.

It’s possible you need to manually enable ‘ENABLE_UART=1’ in config.txt. That was recently discussed here. See that post for more context and let us know if that gets you unstuck.