Walkthrough for Raspberry Pi 4B fails to boot

I am new to mender and trying to get a test running with it. I downloaded the Pi 4B Image from the docs, however the device seems to fail after mounting /uboot.

Is there a newer image out there that I’m not seeing?

HI @rtruran,

Sorry to hear you’re having trouble getting started. I assume we are talking about the images linked here? Just giving it a try too and it indeed seems to behave strangely. Will take it to the team and keep you in the loop.

Greetz,
Josef

Yes thats the one, Thank you for looking into this.

Hi @rtruran,

Sure thing. Unfortunately the bits and pieces do not form a clear image yet. So can you maybe share a few more details?

  • I assume that you see that /uboot mounting fail on the serial console, right? If so, can you please try to capture a full boot log?
  • Did you use the official Raspberry Pi imager as described in the documentation, or some alternative? If so, which? In any case, is there a version number of it? (unless it was dd…)
  • Have you tried another SD card?
  • what size is the SD card you are using?
  • are you using a specific or special version of the Pi4?

To correlate with my findings:

  • I tried with the official imager on two different cards, different sizes
  • On the serial console, the boot progresses for about 10 seconds, then it drops into a reboot-poweroff.
  • A coworker who also checked the image reports that it works for him.

As you can see this is a bit mysterious at the moment… :frowning:

Greetz,
Josef

Interesting.

  1. I can try to get a log.
  2. I’m using the official Raspberry Pi imager v.1.7.3
  3. Yes.
  4. 128GB.
  5. I’m currently using an 8GB PI 4.

My device drops into a poweroff, but never loads up. no display on the HDMI Port, no response from ping, etc.

I am using the network config settings from the imager, perhaps thats the issue.

Hi @rtruran,

More news:

  • I tried using the balena Etcher, and it worked right away.
  • my coworker who confirmed the image working used dd
  • another coworker tried with the Raspberry Pi Imager on Ubuntu 20.04, and he confirms it works.
  • it certainly did not for me, but I am on macOS

So what OS are you on? Can you try again using balena Etcher, in case you’re on macOS or Windows, or dd on Linux?

Greetz,
Josef

I’m on MacOS, I tested out Balena etcher but got the same result.

Hi @rtruran,

tested the Raspberry Pi Imager 1.7.3 on Windows and Linux now, and both work like a charm. One observation is that they both take considerably longer to write (but that can also be due to other hardware), so at least by gut feeling I would now conclude that the Imager has some kind of issue on a recent macOS, presumably due to data syncing.

Can you try to write the image from some Windows or Linux box?

Greetz,
Josef