Toradex Verdin iMX8MM: error building the SDK with Mender


I tried Mender on a Toradex Verdin iMX8MM with BSP v6.0 a month ago following this manual and it worked without problems. But with the last updates of the Mender-repo I got the following errors building the SDK:

$ bitbake tdx-reference-multimedia-image -c populate_sdk
ERROR: nativesdk-util-linux-2.37.4-r0 do_package: QA Issue: nativesdk-util-linux: Files/directories were installed but not shipped in any package:
Please set FILES such that these items are packaged. Alternatively if they are unneeded, avoid installing them or delete them within do_install.
nativesdk-util-linux: 5 installed and not shipped files. [installed-vs-shipped]
ERROR: nativesdk-util-linux-2.37.4-r0 do_package: Fatal QA errors were found, failing task.
ERROR: Logfile of failure stored in: /home/gemac/test/build/tmp/work/x86_64-nativesdk-tdxsdk-linux/nativesdk-util-linux/2.37.4-r0/temp/log.do_package.26665
ERROR: Task (virtual:nativesdk:/home/gemac/test/build/../layers/openembedded-core/meta/recipes-core/util-linux/ failed with exit code '1'

How can I avoid these errors?

Best regards,

Hi @Mowlwurf,

this is caused by the bbappend that Toradex has for util-linux. This adds fstrim: util-linux_%.bbappend « util-linux « recipes-core - meta-toradex-bsp-common.git - Toradex BSP layer, recipes common to all modules

You can work around it for development purposes by just disabling this bbappend by renaming it, it personally add a .defunct to the file name for such purposes.

Besides that, this needs to be fixed in their upstream - pinging @drewmoseley


Hi @TheYoctoJester,

thank you for your fast response.
With renaming the .bbappend-file the building of the SDK works.

Best regards,

@Mowlwurf @TheYoctoJester see my proposed PR here (systemd: Do not modify DISTRO_FEATURES_BACKFILE for mender-systemd config by drewmoseley · Pull Request #1928 · mendersoftware/meta-mender · GitHub) that fixes the root cause of this issue.

I did submit a patch to the Toradex BSP layer which would address the specific bbappend being discussed here but the actual root cause is related to how Mender sets up systemd.