Nativesdk-util-linux do_package fatel QA Errors

I am trying to build a yocto image with mender for Colibri IMX8X.

In my local.conf I have added the following:

MENDER_STORAGE_DEVICE = "/dev/mmcblk0"
MENDER_STORAGE_TOTAL_SIZE_MB = "7264"

MENDER_FEATURES_ENABLE_append = " mender-uboot mender-image-sd"
MENDER_FEATURES_DISABLE_append = " mender-grub mender-image-uefi"
TORADEX_BSP_VERSION = "toradex-bsp-5.4.0"

# This really saves a lot of disk space!
INHERIT += "rm_work"

# The name of the disk image and Artifact that will be built.
# This is what the device will report that it is running, and different updates
# must have different names because Mender will skip installation of an Artifact
# if it is already installed.
MENDER_ARTIFACT_NAME = "release-1"

INHERIT += "mender-full"

DISTRO_FEATURES_append = " systemd"
VIRTUAL-RUNTIME_init_manager = "systemd"
DISTRO_FEATURES_BACKFILL_CONSIDERED = "sysvinit"
VIRTUAL-RUNTIME_initscripts = ""

I have created a patch for colibri-imx8x_defconfig

diff --git a/configs/colibri-imx8x_defconfig b/configs/colibri-imx8x_defconfig
index 256159b060..156f9d00f2 100644
--- a/configs/colibri-imx8x_defconfig
+++ b/configs/colibri-imx8x_defconfig
@@ -2,8 +2,10 @@ CONFIG_ARM=y
 CONFIG_ARCH_IMX8=y
 CONFIG_SYS_TEXT_BASE=0x80020000
 CONFIG_SYS_MALLOC_F_LEN=0x8000
-CONFIG_ENV_SIZE=0x2000
-CONFIG_ENV_OFFSET=0xFFFFDE00
+CONFIG_ENV_SIZE=0x4000
+CONFIG_ENV_OFFSET=0x800000
+CONFIG_ENV_OFFSET_REDUND=0x1000000
+CONFIG_SYS_REDUNDAND_ENVIRONMENT=y
 CONFIG_DM_GPIO=y
 CONFIG_BOOTAUX_RESERVED_MEM_BASE=0x88000000
 CONFIG_BOOTAUX_RESERVED_MEM_SIZE=0x08000000

When I try to bake my image I get the following error:

Apalis iMX8 user. Our team managed to build images with Mender for Apalis iMX8, but met this exact issue when attempting to build our Yocto SDK. These issues seem to stem from meta-toradex-bsp-common’s additions to util-linux.

https://git.toradex.com/cgit/meta-toradex-bsp-common.git/tree/recipes-core/util-linux/util-linux_%25.bbappend?h=dunfell-5.x.y

We haven’t looked deeper into the issue, but managed to apply a workaround by adding:

FILES_${PN} += " ${systemd_unitdir}/system "

to the bbappend recipe, after which we were able to get the SDK built without issues. It is unclear to us whether configuring Mender caused these errors to surface, or if it is simply an oversight by Toradex, or a mix of both.

That does seem to work. The error only seems to occur once the mender layers are included.

I was able to get the image installed on the device but I am seeing a strange issue. My mender client version is showing as “unknown” even though it should be 2.6.1. Also when I run /usr/bin/mender --version

I see:
unknown runtime: go1.16.8

Is this something you have seen before. I build the image using the hardknott branch.