REMOTEPROC in imx7d-pico with Yocto Hardknott (A7-Side) and Zephyr (m4-side)


I truly love the imx7d-pico. I have two here.

I’m trying to do REMOTEPROC on this device.
The first step of populating the folder /sys/class/remoteproc with remoteproc0 I already managed via device tree changes

I need help to add a gpio-leds (the device’s default led) and create the zephyr.elf file via west build. So that when I will use the commands below in the userspace of Yocto hardknott and/or dunfell (A7-side) the led will turn on or off.

Board $> cp zephyr.elf /lib/firmware
Board $> echo start >/sys/class/remoteproc/remoteprocX/state
Board $> echo stop >/sys/class/remoteproc/remoteprocX/state


  1. This device was added by @jorisoffouga on zephyr in 2019:

  1. Remoteproc Api:

  2. Current status of the zephyr.elf build project on github:
    GitHub - neuberfran/pico_pi_m4

Unfortunately, this issue (different from what I had said and thought) has not yet been completely resolved.

What happens is the following:
I have two linux distributions here:
The first is ubuntu 22.04 which produced a yocto-kirkstone image, where indeed this issue was resolved.

Next is ubuntu 20.04 which produced a yocto-hardknott image where this issue remains.

Below is what I said when I thought this issue had been resolved:

I solved When I change Device Tree in the Yocto-A7-Side and enable in DTS RPMsg options



@drewmoseley I couldn’t find the moderator and I couldn’t change this topic to unresolved. I also couldn’t delete the topic where I mistakenly say that the topic is fully resolved, but it isn’t.

@TheYoctoJester can you help here?

Sure thing @drewmoseley.

@neuberfran I removed the “solved” mark. Note though that the post has no recognizable connection to Mender, so while I am okay with keeping it, please do not expect a lot of activity.