Problems with imx_usb on PICO-PI-IMX/

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)

I Solved, but I cant up U-boot

Hi @neuberfran. Welcome to Mender Hub. Hopefully we can help you with this.

From the “new issue 3.png” file it appears you have an Imx6 based system, not imx7. The USB Vendor/Device is 0525/b4a4 which according to the output from the imx_usb run is mx6.

Also, when you post, please copy/paste the actual text rather than a screenshot; it makes it easier to search on. Thanks,

No. I have imx7 pico kit. I had, I have android things installed on it until yesterday.

Hello friend, help me please. I need to show you at least two more images that show when I first gave the sudo ./imx_usb SPL and sudo ./imx_usb u-boot.img commands.

I can’t explain it then. It’s registering to your usb system as the imx6.

Perhaps @jorisoffouga can help since he did the initial implementation of the Pico-Pi platform and likely has the hardware.

neuberfran@ubuntu:~/mender-nxp/build/tmp/deploy/images/imx7d-pico/imx_usb_loader$ lsusb | grep Freescale
Bus 001 Device 019: ID 15a2:0076 Freescale Semiconductor, Inc.

according to this:

But, not solved.

SPL command first result and U-BOOT command first result:

U-BOOT command first result:

Hi @neuberfran where is your serial output? Connect the serial debug. You can see ttyUSB0 in /dev entry

@jorisoffouga yes, I can see ls /dev/tty* result /dev/ttyUSB0

Open ttyUSB0 with tools like microcom or picocom.
With microcom :

$:  sudo microcom -p /dev/ttyUSB0 

@jorisoffouga sudo microcom -p /dev/ttyUSB0
connected to /dev/ttyUSB0
Escape character: Ctrl-
Type the escape character to get to the prompt.

nknown command 'ry ‘help’
I can. What I do now? (pls

@jorisoffouga my u-boot.img file in original directory/folder have lrwxrwxrwx (blue) and in the imx_usb_loader folder have -rw-r–r--(white) . I tried cp -p cp without option, but not solved

@jorisoffouga I have new issue

=> ums 0 mmc 0
MMC: no card present
mmc_init: -123, time 2
** Bad device mmc 0 **

Try “reset” and that should reboot the board. You will get a U-Boot header and other info printed. All of that will be useful in troubleshooting.

Specifically for the ums command, try the following:
=> usb start
=> mmc rescan
=> mmc list
=> mmc info

@drewmoseley @jorisoffouga

=> usb start
starting USB…
USB0: Port not available.
USB1: MXC USB port 1 not yet supported
lowlevel init failed
=> mmc rescan
MMC: no card present
mmc_init: -123, time 2
=> mmc list
=> mmc info
MMC: no card present
mmc_init: -123, time 2

I can-t start pipocom (serial) with my board (imx7d) in eMMC boot mode. I only can start in normal boot mode.

@drewmoseley @jorisoffouga I put ums 0 mmc 1 one and not 0 and I see X (egual d) in
sudo dd if=core-image-base-imx7d-pico.sdmig of=/dev/sdX bs=1M ; sudo sync

But I have failed in boot time after flash:

@drewmoseley @jorisoffouga I need very much opkg command in my yocto image. How to I solve: opkg command not found?

Add the following to your local.conf:

EXTRA_IMAGE_FEATURES_append = " package-management "

@drewmoseley in the new image I have issue with ```
MACHINE=imx7d-pico bitbake core-image-base

I tried everything in this:

but not solved. (export BRANCH=“warrior”)