Raspberry Tutorial - Dashboard does not show "Connect Device"

Newbie here. I’m following the Raspberry Quickstart:


I downloaded the image, wrote it to a SD card, and got my Raspberry Pi booted and connected. Then, as described in the tutorial, I went to the Mender Dashboard and looked for “Connect Device.” There’s no such link/button; merely a link to some help pages (“LEARN MORE”):

Then I put my browser in incognito mode, logged back into my mender account, and tried again. Voila, “Connect Device” appears (this screenshot was taken after I successfully added the device).

I’ve tried logging out of my mender account, clearing cookies, and restarting my browser. same results.

anybody know what’s going on?

@mzedel do you have any input on this?

Update: I’m unable to add a new device regardless of how I access the mender dashboard: chrome, safari, private mode, etc.

Hi Ryu,
That is actually exactly how it is supposed to work, since the “connect device” button is only supposed to be there for the first device as part of the onboarding process. The help section you get sent to, describes ways to connect your device to your account and includes the same instructions as the onboarding steps - except that you will have to set the device_type yourself (since there are so many different boards available).

As to why this worked in private mode:
If you open the Mender UI in private window or a browser you don’t usually use, the UI determines your onboarding status based on some of the device data etc. you see. Depending on how far the different checkpoints for the onboarding are all passed or your connection speed, the button might still appear from time to time in private windows or others browsers. But the status will be saved in your browser local storage to not show the onboarding if you went through it already.

Sorry for the delay - I hope the explanation clarifies things!

Thanks for the reply. I guess I was confused because having diverged from the onboarding process (I wanted to add a 2nd device), it wasn’t at all clear how to accomplish this from the dashboard.

Anyways, I’m set for now.

I agree, very confusing, I just burned half a day trying to figure out how to remove an earlier failed attempt to start again. Not easy to figure out how to remove existing devices, or add the second and beyond.

Anyway chipping in my opinion. :slight_smile: