Raspberry pi 4 won't boot if there is no hdmi cable

I updated all repos and now my Raspberry pi 4 won’t boot up unless I plug in the HDMI cable. The lights turn solid red and Ethernet card is solid. I have to boot with the HDMI Cable on. I tried to disable the HDMI on boot but it didn’t seem to fix the issue.

Not sure if it’s related to mender / rpi but I know the DISABLE_VC4GRAPHICS has now been fixed in mender cause it to turn turn yellow and be all wacky.

Mender is version 2.2

Quick update, so the following config makes the RPI4 boot up now:


and it looks like the


command isn’t working yet for RPI4.

Are you using Yocto? Which branch in that case?

Yeah, that is indeed odd. Given the mention of VC4GRAPHICS I assume this is with Yocto. I’ve done recent testing on both 32- and 64- bit RpI 4 builds and they worked ok with both HDMI and the Pi Foundation Display. I have seen issues with cheap HDMI panels but the full size one I have worked fine.


Yes Yocto with Warrior branch. It was working fine in Feb, but I just updated the repos now and now I had that issue.

I just did a fresh build using the instructions from here and it booted. The only manual change I made was to add “enable_uart=1” to the config.txt file.

Do you have any other local changes in your build?