Problems with imx_usb on PICO-PI-IMX/

@drewmoseley @jorisoffouga

=> usb start
starting USB…
USB0: Port not available.
USB1: MXC USB port 1 not yet supported
lowlevel init failed
=> mmc rescan
MMC: no card present
mmc_init: -123, time 2
=> mmc list
FSL_SDHC: 0
FSL_SDHC: 1 (eMMC)
=> mmc info
MMC: no card present
mmc_init: -123, time 2

I can-t start pipocom (serial) with my board (imx7d) in eMMC boot mode. I only can start in normal boot mode.

@drewmoseley @jorisoffouga I put ums 0 mmc 1 one and not 0 and I see X (egual d) in
sudo dd if=core-image-base-imx7d-pico.sdmig of=/dev/sdX bs=1M ; sudo sync

But I have failed in boot time after flash:

@drewmoseley @jorisoffouga I need very much opkg command in my yocto image. How to I solve: opkg command not found?

Add the following to your local.conf:

EXTRA_IMAGE_FEATURES_append = " package-management "

@drewmoseley in the new image I have issue with ```
MACHINE=imx7d-pico bitbake core-image-base
command

I tried everything in this: https://stackoverflow.com/questions/48132054/unable-to-start-bitbake-server?rq=1

but not solved.https://drive.google.com/file/d/1iERp5zrYw7JWGuU67IUXrRm7SIVTqn9h/view?usp=sharing (export BRANCH=“warrior”)

@drewmoseley @jorisoffouga After I add EXTRA_IMAGE_FEATURES_append = " package-management " in thud branch I have issue to create principal image:

@drewmoseley @jorisoffouga @mirzak I have this issue: ERROR: core-image-base-1.0-r0 do_image_mender: Size of rootfs is greater than the calculated partition space (255082496 > 226492416). This image won’t fit on a device with the current storage configuration. Try reducing IMAGE_OVERHEAD_FACTOR if it is higher than 1.0, or raise MENDER_STORAGE_TOTAL_SIZE_MB if the device in fact has more storage

Because I put EXTRA_IMAGE_FEATURES_append = " package-management " in my conf/local.conf

Where I found options IMAGE_OVERHEAD_FACTOR, MENDER_STORAGE_TOTAL_SIZE_MB in my mender-nxp folder

@mirzak @jorisoffouga @drewmoseley I need help with this issue:

ums 0 mmc 0
MMC: no card present
mmc_init: -123, time 1
** Bad device mmc 0 **
=> mmc list
FSL_SDHC: 0
FSL_SDHC: 1 (eMMC)
=> mmc info
MMC: no card present
mmc_init: -123, time 2

It appears something is wrong with your hardware or that there is no SDCard in the board. UBoot sees device 0 as SDCard. If you want to switch to eMMC, I think running “mmc dev 1” will do it.

@drewmoseley I don’t have sdcard in my imx7d-pico-pi android things start kit

OK. It sounds like you should be using “ums 0 mmc 1” instead. That will share your eMMC as a block device with your PC assuming you have them connected over USB using the proper port on the client.

@drewmoseley My imx7d pico android things start kit died

https://community.nxp.com/message/1214690

@drewmoseley You said: "OK. It sounds like you should be using “ums 0 mmc 1” instead. "

So in the command dfu 0 mmc 0 (which is done earlier in the tutorial) should i do dfu 0 mmc 1?

What about mmc dev 1

I don’t know. Unfortunately I have never used this particular hardware. Based on the output you showed from the “mmc list” command, then it should be mmc 1.

There are likely a few more layers you need to include in your bblayers.conf. At a minimum you will likely need:

The meta-tensorflow layer has a BUILD.md file which should help you get started.

@drewmoseley
@mirzak

My yocto thud 2.6 project not going up.

I have a issue like this: NXP imx8mm evk don't boot.

But my board is imx7d-pico (without sdcard) and tutorial is this: Technexion PICO-PI-IMX7

Before the dfu 0 mmc 0 command (in @jorisoffouga tutorial) I commanded mmc partconf 0 0 7 0 to avoid the error ** Bad device mmc 0 ** in the ums 0 mmc 0 command later. I have never used the mmc dev 1 command.

As shown below link I think the error could be on partition 24.00 MB (unallocated)

How to solve my issue

@mirzak @jorisoffouga @drewmoseley Last screen before ums 0 mmc 0

or ums 0 mmc 1

I put ums 0 mmc 1 because with ums 0 mmc 0 I have issue:

mmc list
FSL_SDHC: 0
FSL_SDHC: 1 (eMMC)
=> ums 0 mmc 0
MMC: no card present
** Bad device mmc 0 **
=> ums 0 mmc 1

AND i have issue below

gparted result and lsblk


@drewmoseley @jorisoffouga @mirzak

Please, help me with this issue:

after saveenv command.
=> mmc list
FSL_SDHC: 0 (eMMC)
=> part list mmc 0
“## Unknown partition table type 0”
=> part list mmc 1
MMC Device 1 not found

dfu 0 mmc 0
Couldn’t find part #1 on mmc device #0
DFU entities configuration failed!
(partition table does not match dfu_alt_info?)
dfu - Device Firmware Upgrade

Usage:
dfu <USB_controller> [list]

  • device firmware upgrade via <USB_controller>
    on device , attached to interface

[list] - list available alt settings

No idea, sorry. I don’t have this hardware any more so it’s difficult for me to do anything here. At a minimum it seems there is something wrong with your partitions on MMC device 0.

Drew

@drewmoseley If I do this worked (I solved dfu 0 mmc 0), But not solved the main issue:. *The .sdimg yocto image not start, Why? (I’m google assistant and cloud iot core specialist and I need this device (with Yocto image) to do this: https://cloud.google.com/community/tutorials/cloud-iot-mender-ota)