Partition names in sdimg


I’m creating SD Card images .sdimg and the partitions in sumo have clear naming as follows,

# sumo
ls /media/ux/
primary secondary  data

Now, I switched to zeus and the partition names are no longer exist,

# zeus
ls /media/ux/
01be7a09-37e9-48fa-972d-5c5282992a6a  01be7a09-37e9-48fa-972d-5c5282992a6a1  data

I would like to add the names as before so,

  1. Kindly update your zeus repo to create sdimg with partition names or
  2. Instruct me to add partition names in my build.

Thanks in advance.

Hi @danie I don’t know why this change was made but it seems to be something fundamental to the underlying WIC support. @kacf is this something that can be done?

1 Like

I don’t think this is intentional, and I cannot explain off the top of my head why it happens. If we look at the zeus branch, we can see that the data label is there. I suppose it’s possible a --label option is also necessary when the wic entry is made, but I don’t think it has any effect when using the rawcopy plugin. This would need to be investigated.

I tried that and if failed with an error about mkdoslabel blah. So I guess the rawcopy option does not support it.

I’ve tried this patch (basically adding --fstype=ext4 --label primary) in zeus branch and it add the volume labels. I’ve tested in imx8mmevk core-image-base build and it’s working without any known hiccups.

diff --git a/meta-mender-core/classes/mender-part-images.bbclass b/meta-mender-core/classes/mender-part-images.bbclass
index 6bc272b1..986fc33b 100644
--- a/meta-mender-core/classes/mender-part-images.bbclass
+++ b/meta-mender-core/classes/mender-part-images.bbclass
@@ -126,8 +126,8 @@ EOF
     cat >> "$wks" <<EOF
-part --source rawcopy --sourceparams="file=${IMGDEPLOYDIR}/${IMAGE_LINK_NAME}.${ARTIFACTIMG_FSTYPE}" --ondisk "$ondisk_dev" --align $alignment_kb --fixed-size ${MENDER_CALC_ROOTFS_SIZE}k $part_type_params
-part --source rawcopy --sourceparams="file=${IMGDEPLOYDIR}/${IMAGE_LINK_NAME}.${ARTIFACTIMG_FSTYPE}" --ondisk "$ondisk_dev" --align $alignment_kb --fixed-size ${MENDER_CALC_ROOTFS_SIZE}k $part_type_params
+part --source rawcopy --sourceparams="file=${IMGDEPLOYDIR}/${IMAGE_LINK_NAME}.${ARTIFACTIMG_FSTYPE}" --ondisk "$ondisk_dev" --fstype=ext4 --label primary --align $alignment_kb --fixed-size ${MENDER_CALC_ROOTFS_SIZE}k $part_type_params
+part --source rawcopy --sourceparams="file=${IMGDEPLOYDIR}/${IMAGE_LINK_NAME}.${ARTIFACTIMG_FSTYPE}" --ondisk "$ondisk_dev" --fstype=ext4 --label secondary --align $alignment_kb --fixed-size ${MENDER_CALC_ROOTFS_SIZE}k $part_type_params
     if [ "${MENDER_SWAP_PART_SIZE_MB}" -ne "0" ]; then

@kacf If you guys can test it more extensively, I’ll be more than happy in providing a helping hand.



I too faced this issue earlier! I think you’ve added --label primary, if so try adding --fstype=ext4 along with --label primary.

I hope it should do the trick.