Mender-connect issue

Hello Mender Community!

I am trying to add the mender-connect feature to my yocto project.

I added the mender-connect package to my image, but when it is running, it cannot connect to the server.

The error message says that the io.mender.AuthenticationManager service is not found.

(Otherwise the mender client in general works fine, remote updates are working)


Feb 06 10:37:05 radxa-cm3-io-rk3566 systemd[1]: Started Mender Connect service.
Feb 06 10:37:05 radxa-cm3-io-rk3566 mender-connect[523]: time="2024-02-06T10:37:05+01:00" level=info msg="Loaded configuration file: /etc/mender/mender-connect.conf"
Feb 06 10:37:05 radxa-cm3-io-rk3566 mender-connect[523]: time="2024-02-06T10:37:05+01:00" level=warning msg="ShellArguments is empty, defaulting to [--login]"
Feb 06 10:37:05 radxa-cm3-io-rk3566 mender-connect[523]: time="2024-02-06T10:37:05+01:00" level=warning msg="call to GetJWTToken on the Mender D-Bus API failed: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name io.mender.AuthenticationManager was not provided by any .service files"



    "ShellCommand": "/bin/sh",
    "User": "root"


    "InventoryPollIntervalSeconds": 1800,
    "RetryPollIntervalSeconds": 300,
    "ServerURL": "",
    "TenantToken": "<my-token>",
    "UpdatePollIntervalSeconds": 180

Project Specs

  • machine: Radxa CM3
  • Server : eu-hosted
  • yocto branch: kirkstone

What I have tried

  1. Stopping, restarting the mender-connect service, manually running /usr/bin/mender-connect - same result
  2. Sending a dbus message to io.mender.AuthenticationManager manually - dbus message failed, no io.mender.AuthenticationManager found
  3. Set another sudoer user instead of root in /etc/mender/mender-connect.conf - same result

Based on the above I have a suspicion that the io.mender.AuthenticationManager really doesn’t exist.

I read in the release documentation that the serparate AuthenticationManager was created in some recent version of the mender-client. This made me think that maybe the mender-client and mender connect versions that I have may not be compatible.

mender-client version:

3.5.1	runtime: go1.17.13

mender-connect version:

mender-connect version 2.1.1	runtime: go1.17.13

Could this be the cause? If yes, how can I find and install the right packages?

Hi @gregszalay,

No, the split of the mender binary into mender-update and mender-auth is in the 4.0 release, the 3.5 series is not affected. The one thing to check would be if the mender-client service is up, running and connected to the backend, e.g. the device is accepted.


Thanks for the fast reply @TheYoctoJester

I don’t see any new authentication requests on the web UI, no devices are in ‘pending’.

The device is online, authenticated, there are no apparent issues with the mender client itself on the device.

In the web UI, the troubleshoot package is enabled, my user has the ‘Connect’ permissions.

If I go to the device’s page, the “Troubleshoot” tab on the web UI still says:

The troubleshoot add-on does not seem to be enabled on this device.
Please see the documentation for a description on how it works and how to enable it.

Also sometimes this pops up (I dont know if this could be related):

There was an error retrieving the configuration for device 61819f44-9aa2-4d54-8cc0-e0c58cb45df6. feature not available in your Plan.... [Request ID: f8f4da66]