Mender client with Ubuntu x64 architecture r

Hi All,

I am new to the world of mender. I am planning to use hosted mender as a server.
In the client side I would like to configure a Intel based gateway which is running with Ubuntu 18.04 operating system and its 64 bit architecture.
So I request anyone to help me to configure this gateway as mender client and do some update using hosted mender server.
First I would like to get some idea about the feasibility of mender on the Intel x64 bit gateway with Ubuntu.

Any kind of support is appreciated.
Thank you


Hello @DipinPK and welcome to the Mender community.

For Ubuntu support and other binary style distributions we provide a tool called mender-convert,

Please note that we currently have a newer (unreleased) version of this tool which does have some initial support for x86_64 and has been tested one of the Ubuntu images. More about this here,

1 Like

Hi @mirzak

Thank you for help.
As I am very new to mender, I am facing some difficulties to configure mender client to my Ubuntu 18.04 (x64) using mender convert. Is there any document clearly explains the steps for doing the same?..
Mender documentation I have referred already, but I would like to get more detailed information for a x64 architecture system.

Sorry if I am asking you a silly question that you answered already :innocent:


We do not have any specific resources that explain the x86_64 (I think that is what you meant) architecture in general and would refer you to the wast resources available on the internet :slight_smile:

I have a gateway with Intel atom processor. I installed Ubuntu 18.04 Desktop version in that. In this device I want to configure mender client and do the update.
I have a confidence that, it is possible to configure mender client on this device. Expecting your comments on this.


It’s possible to install client on Ubuntu 18.x Even I tried and successfully updated mender artifacts.

@test.test12p, U tried on h/w Ubuntu 18.04 desktop version OS and X86 64 bit architecture OR qemo simulation?

Because I have successfully updated mender artifacts on Ubuntu 18.04 X86_64 using QEMO simulation. but I am facing some difficulties to configure mender to my Ubuntu 18.04 (X86_64) hardware using mender convert.

Hi all,
I am working on same thing. I want to install mender-client with ubuntu 18.04 in managed mode. So that i can take advantage of rollback functionality and other. Till now i have managed to install mender-client.deb to ubuntu (18.04) system and can deploy software over the mender server to it. But it is in standalone mode. Now i want to switch over to managed mode. Kindly help me with this.
I am beginner to this field, i hope i am not asking silly question.

Thanks in advance!

Hi @hitesh53G take a look here: QEMU, the FAST! processor emulator (Ubuntu)

You will basically need to take an image of your golden master Ubuntu 18.04 image and run it through our mender-convert utility.


1 Like

@drewmoseley Thanx for quick response. I will try this solution and let you know the results. Thanx once again…

I have executed all steps in given link using config for “generic_x86-64_hdd_config”. It has generated four files under deploy directory that are:

Out of then i have extract the file with extension .img.gz and tried using Ubuntu-Bionic-x86-64-x86_64-mender.img file to install on my desktop system by following normal installation process. But no luck. I am not able to install this img on my system. Please guide me through this.


Few more questions in my mind that are:
How do we install this image on virtualbox VM (with amd-86-64 config)?
Do i need to convert this file to .iso? Or how do we convert it into .iso (Any specific method that need to follow)?

Please follow this topic how to install image to final target topic specifically about installation because topic talks about installing/converting whole setup. You use pregenerated image but installation process should be same.

For virtual box, you don’t need to convert disk image file to iso. You can attach it in the VM storage settings. Also if you are using uefi, tick the uefi box in VM settings.