Google coral system freeze on yocto


I’m using a coral with yocto built with the meta-coral layer with our own software.

The system is running fine otherwise besides a freeze that happens after our software has been running for a few minutes.

We are getting the following kernel messages on the screen right as the system freeze happens:


buck3: failed to disable
imx8m_gpc_pm_domain gpc_power_domain@4: failed to power off the reg-110


buck3: failed to disable
cpu cpu0: failed to scale dc_reg up: -11
imx8m_gpc_pm_domain gpc_power_domain@4 : failed to power off the reg-11
cpufreq: __target_index: Failed to change cpu frequency: -11

These appear to have something to do with the power management of the system. Could it be, that some flag is not set when the kernel is being compiled. The only change I’ve made so far to the kernel configuration is enabling hidraw, as we need that with our software.

The program is taxing multiple threads whenever the freeze happens, so that would lead me to believe that the issue was power / frequency related.

Do you think this has something to do with Mender? :thinking:

As mentioned seems it’s not related to mender integration. Things I would check would be :

  • check power supply (it is powered from USB or so or from power supply?) → try other power supply, stronger one
  • build image without mender + also without custom app and verify if issue persist


I had been developing for a while on yocto, so at first I thought that it could be related to the yocto configuration.

Verified that the issue persists on mendel os as well. Contacted coral support for more help, so this topic can be ignored.

1 Like