Disabling mender artifact compression under Yocto builds


We have a use case where we would like the our .mender artifact and its internal contents to be completely uncompressed. This is because we can achieve dramatically better compression at a later stage of file distribution if the input file is uncompressed.

I see that there are MENDER_ARTIFACT_COMPRESSION and MENDER_DISK_COMPRESSION options for mender-convert (Debian) workflow, but I don’t see an equivalent option for Yocto workflows.

Upon inspection, I see that our .mender file itself is already an uncompressed tarball, but the 0000.tar.gz disk image file within is compressed. We would like that file to be uncompressed, as well.

Does anyone have any tips to go about achieving this?


try adding the following to your local.conf:

MENDER_ARTIFACT_EXTRA_ARGS_append = " --compression none"

1 Like

That did the trick. Thanks!

1 Like