Append bootargs to Grub


Simple question, I recently tested mender on a QEMU machine, but I don’t see how to append “nofg” to kernel bootargs.

I tried to add

To my machine but didn’t have any effect.

I’m on Zeus release,
Thanks for your help.

can your confirm that the arg is making it all the way thru to runtime?

cat /proc/cmdline

[    7.236330] uvesafb: 5000 ms task timeout.
[    7.236690] uvesafb: Getting VBE info block failed (eax=0x4f00, err=1)
[    7.237557] uvesafb: vbe_init() failed with -22
[    7.238584] uvesafb: probe of uvesafb.0 failed with error -22

$> cat /proc/cmdline

BOOT_IMAGE=(hd0,2)/boot/bzImage root=/dev/vda2 console=ttyS0,115200n8 rootwait

Just to be more clear, I don’t use mender-convert.

I build a Yocto image with machine=qemux86-64 and inherit mender-full.

are you using uboot as your bootloader then, as it looks like MENDER_GRUB_KERNEL_BOOT_ARGS is a mender-convert variable.

If using uboot, in the past i have added a patch to add in the CONFIG_BOOTARGS variable to the uboot recipe which meta-mender honours

I’m using grub as bootloader for my VM… :frowning:

maybe you can .bbapend the meta-mender grub recipe to append to the console-bootargs variable, (add another grub config file with larger number prefix to add to the console-bootargs variable)

1 Like

Thanks @dellgreen! this worked perfectly !