Trying to integrate FireFly-RK3288 (Yocto Project)

@mirzak

I have tried the same for FireFly-RK3288 (http://en.t-firefly.com/product/rk3288). This Board is similar to Asus Tinker Board. But it has emmc so I have tried to flash gptimg thru otg. But the U-Boot got hangs in “Loading Environment from MMC”

Can u please help to port it to FireFly-RK3288 eMMC . Please let know what are the parameter has to be changed.

I have change MACHINE = firefly-rk3288 in local.conf
and added MENDER_FEATURES_ENABLE_append = " mender-image-gpt"

Thanks

Hi @karthi welcome to Mender Hub.

I’m not terribly surprised that it has issues in U-Boot. That is generally very board-dependent and the U-Boot fro the Tinker board is unlikely to work on the FireFly board. There does appear to be a firefly-rk3288_defconfig in the upstream U-Boot sources so this likely can be made to work but you will need to build a custom U-Boot and integrated it into mender-convert.

Drew

HI @drewmoseley
I have Set up a Yocto (Pyro) Build for firefly-rk3288 eMMC and which is working fine. Please let me know what changes has to be done for Including mender layer in existing Build setup.

Thanks

Hi @karthi,

The details are here: https://docs.mender.io/2.3/devices/yocto-project
It’s probably easiest in your case to start with the Tinker board configuration as documented on this page but swap out the MACHINE definition. From there just run a build and see what happens. It’s hard to say up front where the changes are going to be.
Drew

Hi @drewmoseley
I have build image using https://github.com/mendersoftware/meta-mender-community/tree/thud for SD card with a small patch for firefly-3288

— a/include/configs/firefly-rk3288.h 2020-04-05 16:59:21.000000000 +0530
+++ b/include/configs/firefly-rk3288.h 2020-04-05 16:59:25.000000000 +0530
@@ -1,6 +1,6 @@
/* SPDX-License-Identifier: GPL-2.0+ /
/

- * © Copyright 2015 Google, Inc
+ * © Copyright 2016 Rockchip Electronics Co., Ltd
*/
#ifndef __CONFIG_H
@@ -9,10 +9,20 @@
#define ROCKCHIP_DEVICE_SETTINGS
“stdin=serial,usbkbd\0”
“stdout=serial,vidconsole\0”
- “stderr=serial,vidconsole\0”
+ “stderr=serial,vidconsole\0”
+ “preboot=usb start\0”
#include <configs/rk3288_common.h>
-#define CONFIG_SYS_MMC_ENV_DEV 0
+#undef BOOT_TARGET_DEVICES
+
+#define BOOT_TARGET_DEVICES(func)
+ func(MMC, mmc, 1)
+ func(MMC, mmc, 0)
+ func(USB, usb, 0)
+ func(PXE, pxe, na)
+ func(DHCP, dchp, na)
+
+#define CONFIG_SYS_MMC_ENV_DEV 1
#endif
\ No newline at end of file

Now I have to build or dump the SD image to eMMC, Please let me know what should be the next step

U-Boot 2018.07 (Apr 05 2020 - 17:40:34 +0000)

Model: Firefly-RK3288
DRAM:  2 GiB
MMC:   dwmmc@ff0c0000: 1, dwmmc@ff0f0000: 0
Loading Environment from MMC... *** Warning - bad CRC, using default environment

Failed (-5)
In:    serial
Out:   serial
Err:   serial
Model: Firefly-RK3288
Net:
Warning: ethernet@ff290000 (eth0) using random MAC address - ae:56:7a:ee:04:6e
eth0: ethernet@ff290000
starting USB...
USB0:   USB1:   scanning bus 0 for devices... 1 USB Device(s) found
scanning bus 1 for devices... 1 USB Device(s) found
       scanning usb for storage devices... 0 Storage Device(s) found
Hit any key to stop autoboot:  0
Saving Environment to MMC... Writing to redundant MMC(1)... OK
40352 bytes read in 7 ms (5.5 MiB/s)
8655360 bytes read in 397 ms (20.8 MiB/s)
## Flattened Device Tree blob at 01f00000
   Booting using the fdt blob at 0x1f00000
   Loading Device Tree to 0fff3000, end 0ffffd9f ... OK

Starting kernel ...


Poky (Yocto Project Reference Distro) 2.6.4 firefly-rk3288 ttyS2

firefly-rk3288 login:

Now I have to build or dump the SD image to eMMC, Please let me know what should be the next step

I guess it’s just a matter of following the manufacturers instructions at this point. It sounds like you have made good progress. I did find the following which may help:
http://wiki.t-firefly.com/ROC-RK3328-CC/flash_emmc.html

Drew