Mender Docker Install V3.4

I deployed the mender version 3.4 today.
Both mender-device-auth & mender-useradm are always in “restarting” state.

I am not able to create the seed user to login.
How do i fix this?

Hi,

Can you provide logs from restarting containers?

@kjaskiewiczz Attached the logs.

deviceauth container

useradm container

@kjaskiewiczz Looks like it is looking at an incorrect location

Hi @TheYoctoJester can you please assist?

@kirklogitech did you resolve the issue? :thinking:

@oleorhagen Nope. No luck yet.

The issue with v3.4 is that a couple of containers do not start and i am not able to use v3.4 after multiple attempts of clean install.

Any help to resolve issues with v3.4 will be helpful.

I faced the same issue here.

Still not find the solution yet.

I hope to get a resolution soon. I switched back to v3.3 for now.

I solved the issue.

See that his data volume is bound /production/keys-generated/keys/deviceauth/private.key
Check whether this private.key has permission

found no permission

$ chmod +777 ~/mender-server/production/keys-generated/keys/useradm/private.key
$ chmod +777 ~/mender-server/production/keys-generated/keys/deviceauth/private.key

$ sudo ~/mender-server/production/run up -d

Change the permissions to full and start again, and you will see the useradm and deviceauth can be activated!

You also can check the 3.3.0’s private.key permission and change the 3.4.0’s to the same permission.

@ak8893893 Thanks for sharing the info. I will have a go at it and let you know how it went.

Another question on SSL. How are you setting up https for the hosted server?

1 Like

Sorry I didn’t know the meaning of you said “How are you setting up https for the hosted server?” very well.

For me.
I edited the host file to link the https domain name.

Go to C:\Windows\System32\drivers\etc\hosts
add your ip and domain name in your hosts file

like this
10.123.456.789 mender.example.com

use your browser to https://mender.example.com/ui/
image

And then you can log in with the account you created.
For example

username=myusername@host.com

password=mysecretpassword

@ak8893893 I am using my own domain and when the mender client on RPi wants to connect it needs a https url otherwise it will fail to connect. How are you ensuring the RPi mender client is connecting to the hosted server.

Use your RPi’s terminal

$ vi /etc/mender/mender.conf

Edit your ServerURL, TenantToken, ServerCertifivate.

If it answerd your question?

I believe unless SSL certificates are installed on the server it will fail.