Mender distribution "not supported" - what triggers this response?

I’m building the BeagleBoneBlack Mender Yocto as provided.
I’ve had to update the Yocto to Dunfell. This builds and runs OK, but on contacting Mender with the supplied demo script, its gets rejected:
“ERROR: your distribution (poky) is either not recognized or not supported.”

The branch I’m building is this:

Thanks in advance


Hi @BenH,

When using a Yocto-based build then the Mender Client is already installed and integrated in the image. The demo script is only for Debian-based images.
So if you have the image running on the BBB, you should be able to use mender setup to connect the device to your Hosted Mender account.


HI Josef,
Thanks for the quick response. I’m just trying that now.

EDIT by @TheYoctoJester: moved this over from other thread, as it is essentially a duplicate.

Old post, but I’ve created a BBB Mender Yocto which boots and runs. It contacts the Mender server which refuses it on account of an unknown disribution
“ERROR: your distribution (poky) is either not recognized or not supported.
Did you test your Dunfell build?
I’v tried going back to Zeus, but that drags in Python3.9 and I get loads of failures in bitbakes. (once downgraded to 3.9 and adding diskutils).

Hi Josef,
I used my github account as my login to and the mender setup is rejecting my attempts to use the email address and/or the password.
I’ve tried requesting a password reset but am not receiving an email.
Is there a way to restart the mender login?

@BenH if you are using a SSO provider such as GitHub, then the username/password flow is not available. You have two options:


I did try the tenant-token but no luck yet.
Is the device-type from an official list, or just the value you entered when generating the TenantToken in the Web GUI?

@BenH the device type is an arbitrary string that you can choose to identify the hardware type to your liking.

On a related note, when doing a Yocto build one usually does not follow the interactive authentication flow. By setting MENDER_TENANT_TOKEN according to the account, and eventually adding the meta-mender-demo layer for a shorter polling cycle, the image is ready for immediate onboarding.


I’ve created a new login with new email and password. This is rejected by the mender setup script every time.
I’ll have a look at adding the tenant to the Yocto build but I was hoping to get a basic test going with the vanilla build.
Is there a test I can run to check connectivity?
When I have run the installation script it seems to be talking to the Mender server OK.

Connecting to (
wget: note: TLS certificate validation not implemented
Connecting to (
writing to stdout
-                    100% |*****************************************************| 22088  0:00:00 ETA
written to stdout

 _ __ ___   ___ _ __   __| | ___ _ __
| '_ ` _ \ / _ \ '_ \ / _` |/ _ \ '__|
| | | | | |  __/ | | | (_| |  __/ |
|_| |_| |_|\___|_| |_|\__,_|\___|_|

Running the Mender installation script.

type or paste code here

type or paste code here

This is the config:

root@beaglebone-yocto:~# cat /etc/mender/mender.conf
    "ArtifactVerifyKey": "",
    "HttpsClient": {
        "Certificate": "",
        "Key": "",
        "SSLEngine": ""
    "Security": {
        "AuthPrivateKey": "",
        "SSLEngine": ""
    "RootfsPartA": "/dev/mmcblk0p2",
    "RootfsPartB": "/dev/mmcblk0p3",
    "DeviceTypeFile": "/var/lib/mender/device_type",
    "DBus": {
        "Enabled": true
    "UpdatePollIntervalSeconds": 5,
    "InventoryPollIntervalSeconds": 5,
    "SkipVerify": false,
    "RetryPollIntervalSeconds": 30,
    "StateScriptTimeoutSeconds": 0,
    "StateScriptRetryTimeoutSeconds": 0,
    "StateScriptRetryIntervalSeconds": 0,
    "ModuleTimeoutSeconds": 0,
    "ServerCertificate": "",
    "ServerURL": "",
    "UpdateLogPath": "",
    "TenantToken": "xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx",
    "Servers": [
            "ServerURL": ""

Tenant blanked.

Should this be working?

2039 root 0 IW [kworker/u2:2-ev]
3110 root 868m S /usr/bin/mender daemon
4052 root 0 IW [kworker/0:0-eve]

I’ve tried increasing the logging level but nothing is output to the file I specified (an empty file is created).

root@beaglebone-yocto:~# mender --version
2.6.1 runtime: go1.14.15
Does 2.6.1 still work?

OK. It’s now working by going straight to adding the Tenant Token to the Yocto build and the server IP address.
It’s appeared in the dash board and I’ve done the demo deployment.
Should be able to move on now.

This is with Dunfell Yocto release.