Mender-client with openssl-3.0

I am trying to build for kirkstone, which pulls in openssl-3.0. When trying to build the mender-client recipe, the build fails with the following error:

| vendor/github.com/mendersoftware/openssl/fips.go:31:7: could not determine kind of name for C.FIPS_mode_set

This appears to be due to the FIPS_mode_set API being removed, as mentioned in the OpenSSL 3.0 Migration Guide:

https://www.openssl.org/docs/manmaster/man7/migration_guide.html

I tried the 3.2.x branch, but it fails in the same way.

Hi @zach-welch-aquabyte!

This is being worked on already as part of supporting kirkstone. I will prepare a workaround to unblock you, but please note that it will not be production ready. Hopefully done by EOB today.

Greetz,
Josef

1 Like

Hi @zach-welch-aquabyte!

This took a bit longer than expected, but there is a version of meta-mender at https://github.com/TheYoctoJester/meta-mender/tree/for-kirkstone that you should be able to build. Please let me know if thats “good enough” for you to continue on the road to kirkstone.

Greetz,
Josef

Hi @TheYoctoJester , there seem some incorrect on these 2.

SRC_URI = “git://github.com/theyoctojester/mender;protocol=https;branch=for-kirkstone-3.1.0”

SRCREV = “087a6d0831454c1d50351c52788f138c453d2f6bt”

I currently encountering fetch error

i tried modify these 2 to below

require mender-client.inc

SRC_URI = “git://github.com/TheYoctoJester/meta-mender;protocol=https;branch=for-kirkstone”

SRCREV = “d252ca7ff4e91df2c303258e0c45a501d7e552c8”

however i still encountering fetch error, do you have any thought?

fixed the revision issue, now seeing this. Will continue debug tmr. Thanks for the fork branch.
mender-client-3.1.0-r0 do_populate_lic: QA Issue: mender-client: The LIC_FILES_CHKSUM does not match for file://src/github.com/mendersoftware/mender/LIC_FILES_CHKSUM.sha256;md5=69a48b331ae876b6775139310ec72f1b
mender-client: The new md5 checksum is 31855a7b533035c7e137482019424a05
mender-client: Here is the selected license text:
vvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvv
1033348db7606a7e61b6484f293847cf8d7a35766efebb97e304d4bd5d7f3f6b LICENSE
b40930bbcf80744c86c46a12bc9da056641d722716c378f5659b9e555ef833e1 meta-mender-core/recipes-mender/mender-client-migrate-configuration/files/LICENSE
b40930bbcf80744c86c46a12bc9da056641d722716c378f5659b9e555ef833e1 meta-mender-core/recipes-mender/mender-wait-for-timesync/files/LICENSE
beb140be4cd64599bedc691a55b2729c9cc611a4b9d6ec44e01270105daf18a2 meta-mender-core/recipes-core/lsb-ld/files/LICENSE
ceb1b36ff073bd13d9806d4615b931707768ca9023805620acc32dd1cfc2f680 meta-mender-demo/recipes-mender/boot-script/files/LICENSE
ceb1b36ff073bd13d9806d4615b931707768ca9023805620acc32dd1cfc2f680 meta-mender-demo/recipes-mender/mender-reboot-detector/files/LICENSE
b40930bbcf80744c86c46a12bc9da056641d722716c378f5659b9e555ef833e1 meta-mender-demo/recipes-mender/example-state-scripts/files/LICENSE
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

@TheYoctoJester
When will mender-client compile issue be resolved in meta-mender, master-next branch Commits · mendersoftware/meta-mender · GitHub.
Any tentative date is planned ?

I tried mentioned [GitHub - TheYoctoJester/meta-mender at for-kirkstone] by correcting SRCREV in mender-client_3.1.0.bb:
-SRCREV = “087a6d0831454c1d50351c52788f138c453d2f6bt”
+SRCREV = “087a6d0831454c1d50351c52788f138c453d2f6b”

It further giving compile error:
| go: github.com/bmatsuo/lmdb-go@v1.6.1-0.20160816100615-69ad631904c9: Get “https://proxy.golang.org/github.com/bmatsuo/lmdb-go/@v/v1.6.1-0.20160816100615-69ad631904c9.mod”: dial tcp: lookup proxy.golang.org: Temporary failure in name resolution
| make: *** [Makefile:82: build] Error 1
| ERROR: oe_runmake failed

Any suggestion to resolve this ?

Thanks
Preeti Sachan

After removing the spurious trailing t in SRCREV, I am seeing the same name resolution failure. However, I was already seeing a similar error in an entirely unrelated recipe with a different dependency, so this likely reflects a broader issue that might not be entirely the fault of the mender recipe. Still, my initial searching has not turned up an obvious solution, so I too would enjoy suggestions for resolving this latest issue.

Hi all, I intentionally referred to the for-kirkstone-3.1 branch, as that is the one that I worked on. for-kirkstone in my private repo is known broken.

We don’t have an official tentative date for kirkstone support yet, but it is actively being worked on and hopefully ready for testing soon.

Greets

@TheYoctoJester ,

We are blocked to Kirsktone build release as mender-client is not yet fixed on GitHub - mendersoftware/meta-mender at master-next.

Any plan to fix mender-client on meta-mender, master-next/kirkstone branch before 30 April 2022 ?

Hi @Preeti,

we are actively working on it and hopefully I can get a buildable state online today or tomorrow. Will ping you once it is ready.

Greetz,
Josef

Hi @Preeti,

the current master-next branch on https://github.com/TheYoctoJester/meta-mender should give you a buildable state. Let me know if you encounter more problems.

Greetz,
Josef