Issue with Mender Artifact signature when using Docker Update Module

Hello everyone,

I downloaded the tool to create the artifacts, but when I try to execute the signature using the keys generated in RSA, the result is always this:

Signature: signed; verification using provided key failed

I tried to also use "- -k

but nothing, at the end of the generation of the artifact, is always unverified.
Could anyone give me a hand?

Thanks in advance.

Hi @wow102 and welcome to Mender Hub!

You are probably experiencing a known issue in mender-artifact (see a few comments above). Try to update your mender-artifact tool to 3.1.0 (should be just a drop-in binary replacement):

Let us know if this helps!

Hi @eystein,

I updated the latest version of mender-artifact (3.1.0-dirty) by downloading and replacing the bin, but nothing to do, it still doesn’t work unfortunately:

Signature: signed; verification using provided key failed

Hi @wow102,
Thanks for testing!
Did you create & sign the Artifact with mender-artifact 3.1.0?

I think the bug was during creation of the signed artifact, not verification, so it has to be created with the new version.

Hi @eystein ,

I don’t know what he did, but I ran the procedure again and the artifact was correctly signed and verified and installed by the Mender client.

Thanks for everything anyway.

@wow102, great happy it now works for you!