Issue with connecting QEMU (Ubuntu) image to demo server

After buildig the mender file and uploading to the server,when try to deploy it to my connected device ,
it failed and i get error that no artifacts, kindly help!!

Hi @arun welcome to Mender hub. If you can describe your setup a bit more that would be helpful. You mentioned a connected device but this page is for QEMU systems. What kind of device are you running and what is the target OS?


hi @drewmoseley i installed qemu emulator but it is asking for localhost login,is there any default password,i tried my system password and root as well

Hi @drewmoseley i am facing the same issue ,i am attaching the snapshot for the same.please find the screensort

not able to get the userid and password

Default login for the provided image is root / password ?

@mirzak thanks it works
but /etc/hosts is not present,vim is not working how do i create the file

vi should be present I think, even though vim is not :wink:

@oleorhagen i tried with both Vim and Vi bouth are not working

That is surprising, to say the least, for a Ubuntu image.

ed maybe? nano?

@oleorhagen i tried nano also

I can confirm this behavior. In fact that image seems to have very little installed. No “ifconfig”, “ip” or many other commands. Where did the input image referenced here come from?


Generated using the following command (mkosi):

mkosi -d ubuntu -r bionic -t gpt_ext4 -b --checksum --password password -o image.raw

Hi @mirzak
when i am using your command it is showing mkosi command not found can you please suggest any solution for that i am attaching my screen shot so you will get better idea and also i am using mender demo server will it work with that because we are not providing any server ip while building the qemu emulator


It looks like you don’t have docker or mkosi installed on your system:

For Docker:

For mkosi, I think you can just run “apt install mkosi”