Issue building Beaglebone Black image in Yocto

Hey everyone, I tried to build my image with the following command : bitbake core-image-base as explained in the tutorial but when I run it, I have several errors:

ERROR: core-image-base-1.0-r0 do_image_wic: Function failed: do_image_wic (log file is located at /home/gianni/delivery/experience/HUB/yocto/build/tmp/work/beaglebone_yocto-poky-linux-gnueabi/core-image-base/1.0-r0/temp/log.do_image_wic.27211)
ERROR: Logfile of failure stored in: /home/gianni/delivery/experience/HUB/yocto/build/tmp/work/beaglebone_yocto-poky-linux-gnueabi/core-image-base/1.0-r0/temp/log.do_image_wic.27211

Here is the content of the logfile :

Can you help me ?

Thank you

Welcome @gianni. Form log it looks like u-boot it not properly build:

ERROR: _exec_cmd: install -m 0644 -D /home/gianni/delivery/experience/HUB/yocto/build/tmp/deploy/images/beaglebone-yocto/u-boot.img /home/gianni/delivery/experience/HUB/yocto/build/tmp/work/beaglebone_yocto-poky-linux-gnueabi/core-image-base/1.0-r0/deploy-core-image-base-image-complete/core-image-base-beaglebone-yocto-grub-20200423082631/tmp.wic.ghwklejl/boot.1/u-boot.img returned '1' instead of 0
output: install: cannot stat '/home/gianni/delivery/experience/HUB/yocto/build/tmp/deploy/images/beaglebone-yocto/u-boot.img': No such file or directory

Can you pls post commands you use for building + local.conf. Thanks.

Hey, @MarekBelisko
The building commande I have used is
bitbake core-image-base

Here is my local.conf :

Hi, do you use above command to perform build? Which branch do you use? Thanks.

Hi, I use the warrior branch and I use the command above

OK thanks. You mentioned you had more problems. Can you pls maybe post whole log? IMO looks like that u-boot was not build (deployed) due unknown reason. What linux distro do you use? Thanks.

I have already sent my logfile
The linux distribution I use is Ubuntu

Can you try to add this to local.conf:

IMAGE_FSTYPES_remove = "wic wic.gz wic.bmap"