Installing .mender image by USB stick

Hi, I am new at Mender and Yocto in general, there is something kind of vague for me when update the .mender image to my device using a USB stick.

I use this command to make the USB bootable:
sudo dd if=<..>/tmp/deploy/images/intel-corei7-64/...-intel-corei7-64.mender of=/dev/sdb

In which /dev/sdb is my USB

After that I plug my USB to the device and use this command (as I found in some instructions):
mender -roofts ...-intel-corei7-64.mender

But there are errors:

Configuration file does not exist: /var/lib/mender/mender.conf module=config
Loaded configuration file: /etc/mender/mender.conf module=config
Mender running on partition: /dev/sda2
Error: rootfs: error while updating image from command line: Not able to open image file:... no such file or directory.

As I understand, mender could not find the .mender image that I transfer to the USB. I have tried to google to understand how this works, but I get stuck as don’t know where to begin. So any help I would appreciate.

just copy the .mender file to your usb as a file, you dont need “dd”

Thank you for your reply.
After reading your reply, I just copy the .mender file to the USB. But after using the mender -rootfs <..>-intel-corei7-64.mender command, it shows the same result as I posted.
Still error not able to open image file.

i you are convinced that the path you are passing is correct the mender command then try copying the mender file off of the USB and onto the internal storage and retry using path to the file on local storage to rule that out.

also check what version of mender client you are using, as the command changed to mender -install at some point

1 Like

Also, make sure there is a filesystem on the SDCard, copy the file from your build system and then mount it on your device. Make sure you can see the file with ls.