How to apply patch manually?


I got the following error when integrating mender in Yocto Zues release.
How to perform patch manually?

ERROR: u-boot-variscite-1.0-r0 do_patch: Command Error: ‘quilt --quiltrc /home/herodev/mender-variscite-zeus/build/tmp/work/imx6ul_var_dart-fslc-linux-gnueabi/u-boot-variscite/1.0-r0/recipe-sysroot-native/etc/quiltrc push’ exited with 0 Output:
Applying patch 0001-Switch-to-CONFIG_DISTRO_DEFAULTS-for-bootcmd.patch
patching file configs/mx6ul_var_dart_mmc_defconfig
patching file include/configs/mx6ul_var_dart.h
Hunk #3 FAILED at 123.
1 out of 4 hunks FAILED – rejects in file include/configs/mx6ul_var_dart.h
Patch 0001-Switch-to-CONFIG_DISTRO_DEFAULTS-for-bootcmd.patch does not apply (enforce with -f)
ERROR: Logfile of failure stored in: /home/herodev/mender-variscite-zeus/build/tmp/work/imx6ul_var_dart-fslc-linux-gnueabi/u-boot-variscite/1.0-r0/temp/log.do_patch.6553
ERROR: Task (/home/herodev/mender-variscite-zeus/sources/meta-variscite-imx/recipes-bsp/u-boot/ failed with exit code ‘1’

I tried to path manually by following the procedure defined in Manual U-Boot integration | Mender documentation but I still encounter same error above.

Gi @marizonne.villafranc

If your patch does not apply cleanly, you will have to resolve the conflicts yourself, manually, and generate a new patch. There is no magic involved here, just manual work, just like you would apply and fix a regular git patch.

Yes. I already did manually. Thanks!

1 Like