Got OSError When Using kas to build an image for Raspberry Pi 4

Board description

Raspberry Pi 4, 64 bit

I have been following this GitHub
URL: GitHub - mendersoftware/meta-mender-community: Community supported integration layers for Mender on various boards

Test results

My host machine is MacBook Pro. In Mac terminal, after installing kas tool and cloning meta-mender-community, I have tried both

  1. Quick start command, “kas build meta-mender-community/kas/raspberrypi4-64.yml”
  2. “kas build …/kas/raspberrypi4-64.yml”

I got pretty much the same results:
OSError: dlopen(, 0x0006): tried: ‘’ (no such file), ‘/System/Volumes/Preboot/Cryptexes/’ (no such file), ‘/usr/lib/’ (no such file, not in dyld cache), ‘’ (no such file)

Btw, I have installed gcc by checking
% gcc --version
Apple clang version 15.0.0 (clang-1500.3.9.4)
Target: arm64-apple-darwin23.4.0
Thread model: posix
InstalledDir: /Library/Developer/CommandLineTools/usr/bin

How to resolve the error? Thank you.

Hi @cin200618,

Building Yocto on Mac OS is not supported, bitbake has some pretty strong requirements to the Linux platform. You can either use a native Linux installation (recommended), or some form of virtualization. For MacOS, maybe check out UTM. To set up a functional build host, please see the documentation: 2 Setting Up to Use the Yocto Project — The Yocto Project ® 4.3.999 documentation