Getting a “no artifact” message from Mender Server when deploying directory update


I’m trying to create and deploy a directory artifact. Creation did work, I could upload to Mender Server, but when I want to deploy, I’m getting a “no artifact” message from Mender Server.

This is how the artifact is recognized by Mender Server:

This is the message I got when trying to deploy this artifact:

When I check the logs on the device, there was never an attempt to install something, in other words, the server did not deploy this artifact.

Any idea what is wrong with my generated artifact?

Edit: I tried to deploy this very artifact to another device. This worked flawlessly. In that case it does not seem to be the artifact itself but my device. What is wrong then? I freshly installed mender client on this device as I have done on others. So there is currently no artifact installed. But that shouldn’t be a precondition to deploy a new artifact, right?

Edit2: I was able to solve my problem. It was linked to a wrong device_type on my client. The following happened:
During setup of the device I had a typo in the device_type in /var/lib/mender/device_type. Although I was pretty sure that I later on corrected it (because it was correctly reported to Mender Server in the inventory), it was still wrong in the local device_type. This lead to the above described situation.

All I did was corrected a second time the /var/lib/mender/device_type and then the deployment worked!