Error using multilib with Mender

I am using Mender in conjunction with Yocto Dunfell. It’s worked perfectly until I attempted to use multilib to use 32bit libraries on a 64bit host.

I added the following to my local.conf (This has worked on Yocto Dunfell without Mender installed):

require conf/multilib.conf
MULTILIBS = "multilib:lib32"
DEFAULTTUNE_virtclass-multilib-lib32 = "x86"

When I try and build the OS after adding the above lines I get the errors:

ERROR: mender-configure-1.0.2-r0 do_package: QA Issue: mender-configure: Files/directories were installed but not shipped in any package:
Please set FILES such that these items are packaged. Alternatively if they are unneeded, avoid installing them or delete them within do_install.
mender-configure: 5 installed and not shipped files. [installed-vs-shipped]
ERROR: mender-configure-1.0.2-r0 do_package: Fatal QA errors found, failing task.
ERROR: Logfile of failure stored in: /home/x/Yocto/arc-os/build/tmp/work/corei7-64-poky-linux/mender-configure/1.0.2-r0/temp/log.do_package.2147386
ERROR: Task (/home/x/Yocto/arc-os/build/../sources/meta-mender/meta-mender-core/recipes-mender/mender-configure/ failed with exit code '1' 

The log file is attached to the post, but I can’t find anything really useful in it. I then followed multiple answers on stackoverflow for similar issues like this to no avail. If I removed the mender-configure from the Yocto image and tried to compile I got the same error but for other Mender modules.

Does anyone know what the issue could be? Thanks!

I don’t know of anyone who has attempted to use multilib before, so this is most likely unsupported (not on purpose, but just because no one has requested it). mender-configure is using ${libdir} to refer to /usr/lib, so I’m a bit surprised that Yocto doesn’t have a standard way of handling that.

Unfortunately I think the only way forward is to look at how other packages do this, and then try to adapt Mender do follow the same pattern. Pull requests for this are most welcome.