Deployment failure due to "Tried maximum amount of times"

We just got a deployment failure over satellite link which tends to disconnect and reconnect numerous times. Although we’ve used this link with no problem in the past, today it failed with the attached (anonymized) log (renamed to yaml to be allowed for upload here).
We have remotely sent mender check-update a few times at the end which probably caused the Forced wake-up from sleep entries.
Any clues as to why this happened and did not carry on downloading?
FAIL-anon.yaml (12.8 KB)

hi @bender

It looks to me as it simply times out, due to too many broken connections during an update.

2021-12-07 11:59:00 +0000 UTC error: Artifact install failed: Payload: can not install Payload: core-image-base.ext4: Cannot resume download: Tried maximum amount of times

See also this.

Hope this helps.

We were not aware of this retry limitation as we have deployed many times before and never seen this. As the linked post suggest, increasing the variable does not mean it will solve the problem… Need to look into this one another way…
Thank you

1 Like