Can't create release from a fresh installation on Ubuntu 18.04 LTS on AWS

Hello everyone,

I’m having some issues running the mender-server 2.4.1 integration repository, and hope to get some direction here. I followed the mender documentation at version 2.4 and setup a server on a Ubuntu 18.04 LTS on AWS.

For the initial test, we tried out the demo and it worked with small text files and config files and so on with the single-file update module, on our development board based on rk3399. But we couldn’t push larger binary files and we thought this will be resolved by a production setup.

So I followed the 2.4 documentation at to setup a new instance. I did confirm that ./run ps within the production directory shows every service is up, and I can access the web UI and minio service, and my new device showed up in the device tab. But now I can’t create a release, it just never shows up. After upload progress bar goes to 100%, it simply shows a message “upload successful” and then nothing shows up in the release tab.

I searched mender hub forum and found two topics here and here that might be similar to my situation.

I thought this might be related to minio stoarage service, so I logged into minio service to see if files were getting created, and confirmed that they did. And it seemed like the file size did match the files that were uploaded.

Also I read somewhere on the forum that mender 2.3 had some ui related issues and people worked around it by using a different browsers. Even though I’m using 2.4.1 and the comment asserted that 2.4.1 got that ui bug fixed, I tried using different browsers anyway. I use firefox and I tried uploading a release with chromium, and safari, but no luck. Also I tried to setup a new environment and keys using ip address, Public IPv4 DNS from AWS, and a dynamic dns domain. Nothing worked so far.

Right now I’m guessing this might be related to certificates, that there might be a service that is failing to talk to minio service or something. I don’t know the internals of menders that well yet, so this is at best a wild guess.

I’m desperate to resolve this issue, any help would be much appreciated.

Hello @jesse

thanks for giving Mender a try!
could you open developer tools in your browser (in Chrome it is under right mouse click and “Inspect”), choose “Network”, clean the output, then try the upload, and send me the screen shot of the “Network” output?

best regards,

Hello @peter

Thank you for a reply! Here is the screenshot of devtools network panel after issuing release upload.

And here is another screenshot of uploaded artifact getting created in minio.

Does anybody have any suggestion on how I should troubleshoot this?

Hello @jesse

I am sorry for the delay. could you send the screenshot of the “Console” tab second to the left of the “Network”, and also output from:

docker ps | grep deployments | awk '{system("docker logs "$1);}'

would be nice.


Thanks for a reply @peter. I’m out of office but I’ll upload this today.