Cannot set custom Default device identity attribute in UI

I am using mender 1.7.0 and have added my own Serial number in the device identity as you can see but I cannot set it up as default one. I followed


Is there anything else to do?


1 Like

@michaelatmender any input on this?

@dbensoussan Thank you for pointing this one. Even we faced the same issue with mender demo server.
The link you provided is only for Mender client. I believe, we need to modify the Mender server part to take the new identity on the UI. Currently, it set to only the Device ID (which server allocate) and MAC ID (only Ethernet MAC ID) from the UI perspective.

Yes, this is a known bug - poor implementation of the custom identity feature, really. There is a fix in master branch of the gui, but for now I think you can work around by making sure the test devices or virtual devices are decommissioned (not just removed, but decommissioned completely).

The problem appears when you have your first devices having only Device ID and mac, then add a device later with different id attributes. If all devices on the server have the Device ID, Serial Number and mac attributes, those should all show in the dropdown. If you have an old device that’s missing the Serial Number, it won’t be available in the dropdown.

1 Like

Thanks for the answers.
@michaelatmender I just tried switching to master and restart the containers but got the same results.
There are 2 devices I wouldn’t like to decommission, would there be another workaround?

@dbensoussan I don’t know of any other workaround. Here is the commit where the fix was introduced:

Did you ensure the containers were definitely refreshed to latest master when they were restarted? I can’t immediately think of any other reason why the fix shouldn’t have reached you, I know I’ve been caught with stale containers in the past when switching between branches. We can try to reproduce in the meantime

@michaelatmender, you’re right. I used ./run down, then ./run up -d to start the containers.
This doesn’t download latest master stage containers. I ran ./run pull to fetch latest master containers and it works perfectly now :slight_smile:

1 Like

@dbensoussan I’ve been there before a few times :grin: glad it’s now working for you!