Bumping project from thud to dunfell issue with MENDER_STORAGE_TOTAL_SIZE_MB


I have RPI based project based originally on thud poky release and I’m in process of bumping existing project to dunfell branch. All went smooth but I have an issue with creating sdimage where wic creation failed with messages that actual rootfs size is higher then computed:

ERROR: File system image of partition None is larger (425984 kB) than its allowed size 409600 kB

Thing is I cannot increase MENDER_STORAGE_TOTAL_SIZE_MB because then I cannot perform mender update from thud to dunfell. I tried to adjust various variables but without success.
Does anybody resolve such problem? Ideas? Thanks.

I had a similar issue going from Sumo to Dunfell. But in my case I was able to fix it by adjusting MENDER_STORAGE_TOTAL_SIZE_MB.

@kacf any ideas?

My problem is that I want to be able to switch back from dunfell to thud releases. So for thud rootfs size was 413M. I played with MENDER_STORAGE_TOTAL_SIZE_MB but cannot make image with rotofs which fits to 413MB.I think it’s due to the fact of automatic rootfs size computation was changed or so. Thanks.

You mean you can’t get it to fit exactly, or you can’t get it to decrease at all?

Does it work to set IMAGE_ROOTFS_SIZE to the desired value?

Hi, I would like to have dunfell release have same rootfs size. I tried also to set IMAGE_ROOTFS_SIZE to exact rootfs size but it IIRC I get an issue with size mismatch.

I can’t reproduce this, can you post the output?

We workaround it by setting exact IMAGE_ROOTF_SIZE and with help of this fix: MENDER_PARTITION_ALIGNMENT, Raspberry Pi and historical reasons