Avoiding application update module corruption during rootfs image generation

I was following the tutorial on docker-compose application update (Tutorial: Docker Compose update | Mender documentation) and I wanted to make a rootfs image that already has all the dependencies and update modules. However, sometimes (happened to me twice so far) the module itself or the mender-app.conf file gets corrupted and consequently I am unable to do the docker-compose app updates (it is stuck in downloading phase).

I am generating the image using “mender-artifact write rootfs-image” through ssh. The device I am playing with is raspberry pi 4.

I cannot identify what the problem might be. Is there a way to reliably avoid this? (currently I just make another image)

Hi @lubka,

At least so far I’ve never heard of this. What does “gets corrupted” mean in this context? Is there any specific data defect that you can use to judge it, or is it more like a “try and find out”?


Hi Josef,
the corrupted files look like this:


I know for sure that the problem is with the image itself because the corruption is there no matter how many times or to what device (tried another rpi 4 with same result) I deploy this image and the files were all right on the golden device before I made the image.
I usually find out that they are corrupted when I attempt an application update (either docker-compose or k8s) and it fails or gets stuck.