Artificat creation using mender convert throws error

While creating artifact from raspbian OS golden image (for Rpi4), it throws ERROR!

I am following the process mentioned in
I have taken fresh Raspbain OS , flashed sd card, and created golden image from sd card. Copied golden image to hard disk and using the mender-convert command, initiated to convert golden image in the artifact, but ERROR happened " Wrong fs option, bad option, bad superblock…" Please help

Screenshot attached

1 Like

what file system is your build host running on? ext4, zfs, btrfs as it seems to be complaining about that

I suppose it would be ext4 since I have just downloaded Raspbian OS and flashed it on sd card for Rpi4.
lsblk -f tells me about ext4. I have then expanded filesystem using raspi-config to get additional space? Can that be an issue?

1 Like

Apologies, I mean your laptop or PC where you are running docker-mender-convert script :slight_smile:

That is also ext4, running on ubuntu18.04

After running mender-convert, is there any info near the end of dmesg output? Sometimes it gives more information than mount itself.

similar issue discussed here:

Still, I could not follow towards the solution. Can it be more precise, what exactly I could do to resolve it?

I am able to resolve this by creating golden image in the workstation rather than the target board.
Now I got my *.img and .mender files
When I have flashed *.img file (generated from mender-convert) in sdcard, I could not ssh into the board. I have even created an empty ssh file in boot partition of sd card (as required with Rpi) but no success. What could be the issue? I have written the image file twice on sd card but in both iterations, I am getting a similar result; not able to ssh in Rpi board. Please guide

I would attach monitor and keyboard to rpi4, and login at terminal and check the networking setup, and then check the SSH Daemon is running

I am using Rpi4. I have connected to monitor but after the initial raspbian screen, it could not boot further and shows curser. it does not give a command prompt.
Steps I am following:

  1. Download Raspbian OS
  2. Flash it into sd card.
  3. Put sd card in card reader, coneect to laptop and create golden image using dd command
  4. Download mender-convert from git ```
    git clone -b 2.5.0 GitHub - mendersoftware/mender-convert: An easy way to integrate the Mender client into an existing im
5. ./docker-build
./scripts/ \
    --output-dir ${PWD}/rootfs_overlay_demo \
    --tenant-token "Paste token from"
7. mv <PATH_TO_MY_GOLDEN_IMAGE> input/golden-image-1.img
8. in mender_convert_config file, I have updated variables:
MENDER_ARTIFACT_NAME=release-1 ./docker-mender-convert \
    --disk-image input/golden-image-1.img \
    --config configs/raspberrypi3_config \
    --overlay rootfs_overlay_demo/
10. Image and artifact is created in deploy folder.
11. Now, flash patched image file in sd card and try to boot!
12. Does not boot!!!

Where is the problem in my flow?? Please guide

When uploading generated rootfs mender artifact and sending it to pi, it says " No compatible artifact found"
Screenshot attached

In your commands you use “raspberrypi3”, but in the UI I see “raspberrypi4”. Could this be the problem?

I though of that…I have checked it with raspberrypi4 in command. Still the same issue!

What about our official downloadable Raspberry Pi images. Do those work?

I had tried couple of months back, it worked in January.
I have followed similar approach 1-2 week back using mender-convert and it worked. Since I did not noted that so cant reproduce it now and I am stuck. Not sure where I am going wrong

Not sure why but after following similar steps, I was able to use mender-convert generated *.img and *.artifact file with Rpi3. I am able to get 4 partition, abe to boot and send rootfs update using Rpi3. No problem at all…Rpi4 was causing issues here.But why?

After sending rootfs update to pi, it completed 99% and showed message rebooting.
ssh was also disconnected. I tried but could not ssh. into pi
After waiting for sometime, I power off board, and tried to reconnect. I was able to login in pi but in old partition and in Hosted dashboard, it says “failed”…Why?

Resolved. No problem with pi4 also.
Exactly same process!