SolidRun ClearFog Base

Board description

ClearFog Base SBC is equipped with numerous I/O options, and is compatible with a variety of power, memory and storage configurations. Device makers can easily bridge a variety of different network standards like LAN, Wi-Fi, Cellular, Fiber and DSL, as well as utilize mikroBUS boards for IoT type networking standards such as ZigBee, Sub GHz, Bluetooth and others.

clearfog-base-with-som-01-300x300

URL: https://www.solid-run.com/marvell-armada-family/clearfog/
Wiki: https://developer.solid-run.com/

Test results

The Yocto Project releases in the table below have been tested by the Mender community. Please update it if you have tested this integration on other Yocto Project releases:

Yocto Project Build Runtime
thud (2.6) :test_works: :test_works:

Build Means that the Yocto Project build using this Mender integration completes without errors and outputs images.
Runtime Means that Mender has been verified to work on the board. For U-Boot-based boards, the integration checklist has been verified.

Getting started

Prerequisites

  • A supported Linux distribution and dependencies installed on your workstation/laptop as described in the Yocto Mega Manual
    • NOTE. Instructions depend on which Yocto version you intend to use.
  • Google repo tool installed and in your PATH.

Configuring the build

Setup Yocto environment

Set the Yocto Project branch you are building for:

# set to your branch, make sure it is supported (see table above)
export BRANCH="thud"

Create a directory for your mender-clearfog setup to live in and clone the
meta information.

mkdir mender-clearfog && cd mender-clearfog

Initialize repo manifest:

repo init -u https://github.com/mendersoftware/meta-mender-community \
           -m meta-mender-clearfog/scripts/manifest-clearfog.xml \
           -b ${BRANCH}

Fetch layers in manifest:

repo sync

Setup build environment

Initialize the build environment:

source setup-environment clearfog

Configure Mender server URL (optional)

This section is not required for a successful build but images that are generated by default are only suitable for usage with the Mender client in Standalone deployments, due to lack of server configuration.

You can edit the conf/local.conf file to provide your Mender server configuration, ensuring the generated images and Mender Artifacts are connecting to the Mender server that you are using. There should already be a commented section in the generated conf/local.conf file and you can simply uncomment the relevant configuration options and assign appropriate values to them.

Build for Hosted Mender:

# To get your tenant token:
#    - log in to https://hosted.mender.io
#    - click your email at the top right and then "My organization"
#    - press the "COPY TO CLIPBOARD"
#    - assign content of clipboard to MENDER_TENANT_TOKEN
#
MENDER_SERVER_URL = "https://hosted.mender.io"
MENDER_TENANT_TOKEN = "<copy token here>"

Build for Mender demo server:

# https://docs.mender.io/getting-started/create-a-test-environment
#
# Update IP address to match the machine running the Mender demo server
MENDER_DEMO_HOST_IP_ADDRESS = "192.168.0.100"

Building the image

You can now proceed with building an image:

MACHINE=clearfog-base bitbake core-image-base

Replace core-image-base with your desired image target.

Using the build output

After a successful build, the images and build artifacts are placed in tmp/deploy/images/clearfog-base/.

  • tmp/deploy/images/clearfog-base/core-image-base-clearfog-base.sdimg
  • tmp/deploy/images/clearfog-base/core-image-base-clearfog-base.mender

The disk image with .sdimg is used to provision the device storage for devices without Mender running already. Please proceed to the official documentation on provisioning a new device for steps to do this.

On the other hand, if you already have Mender running on your device and want to deploy a rootfs update using this build, you should use the Mender Artifact files, which have .mender suffix. You can either deploy this Artifact in managed mode with the Mender server as described in Deploy to physical devices or by using the Mender client only in Standalone deployments.

References

  • The official Mender documentation explains how Mender works. This is simply a board-specific complement to the official documentation.

Known issues

SolidRun does not provide an official Yocto BSP for the ClearFog Base boards and this integration is based on a layer that I have created which can be found here:

I am on the lookout to find a better location for above code.


If this post was useful to you, please press like, or leave a thank you note to the contributor who put valuable time into this and made it available to you. It will be much appreciated!

2 Likes

Hi Mirzak,
I am using Solidrun imx6 board and I have built image using your manifest-clearfog.xml and generated .sdimg. But Board unable to boot… Dont know whether its because of difference between your integration meant for solidrun clearfog base and my board is solidrun imx6…
Any suggestions from you…?

This is only for the ClearFog Base board which is based on Marvell SoC, and will not work on Solidrun i.MX6 based devices.

A post was split to a new topic: Solidrun i.MX6 integration errors

Hi Mirzak,

I wasn’t able to get this to run on the eMMC or when booting from USB on ClearFog Base. I have been able to boot the Debian image successfully from the eMMC. Have you tested the images produced and have been able to boot? I should also say I didn’t modify the recipes other than activating hosted mender and putting in my token.

Hi @henzigen,

No this was never tested using eMMC as I did not have an eMMC module when I did this integration. This has only been tested using SD as boot medium. I should probably have put a note on this in the tutorial.

With that said it might work with eMMC, if you add the following in e.g local.conf:

 MENDER_STORAGE_DEVICE = "/dev/mmcblk1" 

As I assume mmcblk0is the SD card.

Thanks for the quick reply. The eMMC is actually mmcblk0 if you order the eMMC version and the sdcard slot is disabled. It’s one or the other.

So I followed the guide here but instead replacing the debian image with the image built with yocto. The eMMC has two boot partitions, and a data partition. The guide provides a u-boot-mmc to dd onto boot partition 0 and then set the eMMC to boot from there. When I did that, it failed to boot but interestingly enough it did have some messages regarding mender-setup not being defined. I also tried to set the eMMC to boot directly from the data partition because I see that /dev/mmcblk0 ends up having 4 partitions (boot, data, primary, secondary) but that fails completely. No boot messages at all. I was thinking of dd’ing the /dev/mmcblk0p1 onto the eMMC boot parition 0. Do you think that would work?

This probably means that you did not get the correct U-boot binary flashed as it is trying to execute the following,

But it wont be that easy and this probably requires some additional integration work. If i recall correctly, they have different U-boot configuration depending on where you will load it from, so you need to adjust this,

Also the sdimg can not have an embedded U-boot for eMMC so you would need to manually write it after you have flashed the sdimg, and this is the command according to Solidrun docs that you execute on a running system to flash U-boot,

  echo 0 | sudo tee /sys/block/mmcblk0boot0/force_ro
  sudo dd if=u-boot-spl-mmc.kwb of=/dev/mmcblk0boot0 conv=sync
1 Like

Mirzak, you’re amazing. That did it. I added UBOOT_BINARY = “u-boot-spl-mmc.kwb” and ran bitbake. It produced “u-boot-spl-mmc.kwb”. I flashed that to boot 0 parition of eMMC and it worked perfectly. The device popped up on my hosted mender. Thank you so much for your help.

1 Like

Glad it worked out for you.