Server upgrade from 1.5.x to 1.6.1

Hi there,

I’m trying to update my production to version 2.0.1. I just tried to follow the documentation but something weird is happening.

When a tried to merge with the tag 1.6.1 some git conflicts appears.

git merge 1.6.0 --no-ff
Auto-merging tests/tests/
Auto-merging other-components.yml
CONFLICT (content): Merge conflict in other-components.yml
Auto-merging extra/
Auto-merging extra/license-overview-generator
CONFLICT (content): Merge conflict in extra/license-overview-generator
Auto-merging docker-compose.yml
CONFLICT (content): Merge conflict in docker-compose.yml
Auto-merging docker-compose.tenant.yml
CONFLICT (content): Merge conflict in docker-compose.tenant.yml
Auto-merging docker-compose.client.yml
CONFLICT (content): Merge conflict in docker-compose.client.yml
Automatic merge failed; fix conflicts and then commit the result.

But I didn’t change anything in these files. Any ideas?

I’m using documentation bellow

Hi @juliosmelo ,

Welcome to Mender Hub. I’m not sure why you would have reported conflicts in those files, but since you didn’t modify them, you can just accept the changes from the new tag.


First of all. Thanks for your time and help @drewmoseley. I really appreciate. Let me ask a question. Do you know if is possible just backup database in the version 1.5.1 and just restore the data in a new server instance in the version 2.0.1?

I don’t know. We generally only test upgrades one release at a time so I would suggest you move through 1.6, 1.7 and then 2.0.

Thanks so much @drewmoseley I upgrade my server to 2.0.1