Rootfs Switch Not Occurring on Raspberry Pi 4-64 with meta-mender Kirkstone

Hello,

I’ve been building images for raspberry pi 4-64 using the latest kirkstone branch of meta-mender.

After updating the OS with an image built from this branch, I encountered an issue where the rootfs switch does not occur, and the system always boots from partition A (/dev/mmcblk0p2).

Upon investigation, it appears that the issue stems from MENDER_FEATURES_ENABLE not having mender-update-install specified, resulting in the cmdline.txt patch not being applied.

There is a process in the following recipe that changes the root in cmdline.txt to ${mender_kernel_root} when mender-update-install is enabled:

With our previous configuration using the Go-based mender-client, we used mender-full.bbclass, which only utilizes mender-client-install (without specifying mender-update-install).

Is it possible to adjust the setup so that specifying only mender-client-install also allows for successful OS updates?

Thanks for bringing it up @nomtor0204!

Just so I understand correctly, this occurred alongside bumping to the Mender Client 4.0?

Greets,
Josef

Hi @TheYoctoJester ,

this occurred alongside bumping to the Mender Client 4.0?

No, this issue occurred with a build of mender-client 3.5.2. I have not bumping to Mender Client 4.0.

The trigger was updating the meta-layer repositories. I noticed this issue when I updated poky from kirkstone-4.0.15 (around 2023/12/25) to kirkstone-4.0.16 (around 2024/02/08) and updated the meta-mender kirkstone branch to the latest.

I have not specified a PREFERRED_VERSION for mender-client, so the latest 3.5.2 available in kirkstone is being built.

Hello,

I am also facing same issue with the mender client.
After the upgrade using ‘mender install <.mender artifact>’, the reboot is not switching to the other rootfs partition.
This issue is found with latest version of the meta-mender layer (commit id: 2eea9e6766f8b4c914c995fb1209f59c86643619).
Mender client version: 3.5.2 runtime: go1.17.13

Basically the mender based fw update fully broken!!!. please fix it asap.

Thanks.

Sounds serious. There is a related discussion in this pull request; I couldn’t reproduce it at the time, but maybe it’s easier to reproduce with the RPi.

We’ve created MEN-7039 to investigate it.

Btw, the latest official tag, kirkstone-v2023.12, should still work, so I encourage you to stick with that until this gets fixed.

Hi there, I tried with both kirkstone-v2023.12 and kirkstone-v2023.10 but couldn’t get either to perform a rootfs switch. Also attempted the MENDER_FEATURES_ENABLE method that was described in another post relating to this with both versions and had no change in the result. Any idea why this would be the case? I have a feeling it might be something on my side at this point but no idea what it could be.

I’ve also noticed this PR which potentially fixes it, but didn’t seem to change anything for me when I built it

If the rootfs switch doesn’t work in kirkstone-v2023.12 for you, then it is probably a different problem, since it works for others. Unfortunately the PR is unlikely to help you since this only fixes the specific problem which was introduced after kirkstone-v2023.12.

But otherwise yes, that PR is indeed an attempt at fixing the problem with the mender-update-install feature. If someone wants to test it, it would be great!

Yeah after checking a bunch of different tags yesterday I started to come to the same conclusion as well that it might be something elsewhere instead (potentially something on my end). I’ve opened a separate thread for that.

Hi @kacf,

I tried this PR. I have confirmed that the issue has been resolved. Thank you for your support.