Restart device and update existing python file in RPi

Hi @oleorhagen,

Im facing one more issue with my deployment, Once a deployment failes or aborted, the release\artifact is tagged with “Inconsistent” name, and after that the device is never synced in real time update, and because of this I cant deploy any further releases unless I restart the device manually, which is a very unfavourable situation for Mender isn’t it.

In general I would recommend using another tool for rebooting your entire fleet. It could be done with an update module like:

#! /bin/bash

set -e

STATE="$1"
FILES="$2"

case "$STATE" in
    NeedsArtifactReboot)
        echo "Automatic"
        ;;
esac
exit 0

However, this is slightly cumbersome, as it would change the artifact name installed. There is simply no way around it.

1 Like

Sure @oleorhagen, I understand this reboot is not happening for now, Now Ill give a try with the state script u have mentioned… Changing the artifact name isn’t a nice way actually. But Ill try this once.

@oleorhagen Any idea on this ?

@nishad1092 this is not a state-script.
It is an update-module

Sure, I’m looking into now, Looks different way to execute\deploy this to a device.

The inconsistent state is related to a failed update-module update.

I’m going to need a little more information on what exactly you are trying to do?

Is this from the script update-module?

Yes, It is from the script module, Few times it worked fine, But twice it failed and yes, It went to “Inconsistent” mode, But after that, the device stopped taking real time update.

Hi @oleorhagen,

Im facing this lke I mentioned 2 days back, One of my deployment is failed and current software I can see “Inconsistent”, after this Mender deployment isnt happening, deploy is stuck in ‘pending. Why all this happening, device type and every detail is fine.

I think this might be helpful :slight_smile:

@oleorhagen So this is a bug which has not been resolved?

No, this is a feature ticket.

Im very sorry @oleorhagen, I couldtn reply u sooner. What is this ticket, I can see its open, and this is what Im looking for I guess, Still I couldnt resolve it, Im not able to deploy any further releases to the device because of a past failure deployment and causing it to be "Inconsistent " artifact. I think I’ll have only one option to decommision, But even after decommission, no change. :frowning:

Hi @nishad1092.

From what I understand the device should still be able to take a new update.

What exactly is the script doing? Is trying to reboot?

Hi @oleorhagen, Im using dir module to deploy a directory of two python files, and its done, and further execute the python file using .sh script module. And it fails for some reason, Even if it fails , it shouldnt cause these many issues right, The Entire mender is slow, and freezy, and now can’t deploy update to taht device also.

Could you post a deployment log here?

all the logs are gone when I decommisioned it. Well, let me try to get it and Ill share it here sooner.

@oleorhagen,

Hi, Could you genuinely tell me, If I power up a production server, will it be smoother than the Demo server I have now?
Tell me please, So I can confidently say No to Demo server, Because Im trying to evaluating this platform. Have u faced these issues in Demo server. Even the server GUI is freezy and stuck mate.

No.

Honestly, I have never encountered any of these issues. Or heard about a single person having this many issues.

Obviously, I cannot make any guarantees as to the quality of the production setup for you, since you been having a lot of issues with the setup that is unfamiliar to me. Especially the GUI freeze.

I even gave the demo a try locally just now, and it works just fine for me. Both locally on my desktop, and on a lower-powered setup I have at home.

We have even done scale-testing of this previously, with tens of thousands of devices, and still no GUI freeze.

If you are to receive any fruitful feedback from us on these issues you are having you need to provide the information that is needed in order for us to reproduce this, otherwise there is no way we can help you with this.

That is information on machine, OS, commands you’ve run. Logs, statistics and observations, etc.

Sure @oleorhagen Ill be happy to provide you with any logs or info.

Okay, since you have clarified on my issues are very unfamiliar, I will setup the demo server once again in a new server with sufficient requirements, and if it again occurs then we can take it further with “why” and "how to resolve it " rgt?

Let me setup a new server of Demo version. I hope all these issues wont occur again. Wow, You just mentioned thousand of devices in a demo server? but they have mentioned only 500, How to get few more ?

I would really like to thank you for all these responses, I’m really looking into Mender, I want this to work, Mender looks very interesting !!