Raspberry Pi CM3+ Error message

Hi Community,

I use the cm3+ modul i get following error:

DRAM: 948 MiB
RPI: Board rev 0x10 outside known range
RPI Unknown model (0xa02100)
MMC: mmc@7e202000: 0, sdhci@7e300000: 1
Loading Environment from FAT… WARNING at drivers/mmc/bcm2835_sdhost.c:408/bcm2835_send_command()!
WARNING at drivers/mmc/bcm2835_sdhost.c:408/bcm2835_send_command()!
*** Warning - bad CRC, using default environment

Is the CM3+ Modul already supported?

How did you build this image?

This way:


./docker-mender-convert from-raw-disk-image --raw-disk-image $RAW_DISK_IMAGE --mender-disk-image $MENDER_DISK_IMAGE --device-type $DEVICE_TYPE --artifact-name $ARTIFACT_NAME --bootloader-toolchain arm-buildroot-linux-gnueabihf --storage-total-size-mb 7448 --demo-host-ip $DEMO_HOST_IP

Edit: @mirzak: apply syntax highlighting

It seems that CM3+ is not supported in the U-boot version we are currently using in mender-convert, which is 2018.07.

It is lacking this commit,

Hi mirzak,

thank you for the answer - so there is currently no fast way to get this solved?
Is it possible to fix this with commercial support?


thank you for the answer - so there is currently no fast way to get this solved?

One either has to update U-boot or backport the necessary patches.

Is it possible to fix this with commercial support?

This is definitely a possibility.

Ok, I sent you a mail.

Hello, I would like to use cm3 + to use mender-convert in a buster image, has this topic of this thread been corrected, or is it still necessary to modify it on the board?

mender-convert is still using U-Boot 2018.07 which does not contain the necessary parts for CM3+ support.

So the comments still stand.

if img is generated from yocto could it work? if the meta of mender is included?
we have mender-server 2.1 hosted locally.

What branch do you recommend for cm3 + to create yocto recipe?

Thank you very much for your help, and congratulations for the project.

I think you would need to use the warrior branch to support CM3+.

Try the steps described here Raspberry Pi Compute Module 3, but set BRANCH="warrior" instead of sumo which is currently described in the post.

Ok!, thanks for your help mirzak :slight_smile:
I try it.

The upcoming release of mender-convert is using U-Boot version 2019.01 and this should have been resolved,

Instructions should be identical as Raspberry Pi 3 Model B/B+ Raspbian

1 Like