Mender update 'hangs' after reboot when polling interval is 0


i have a tegra tx2 running mender-client on yocto zeus. I set MENDER_UPDATE_POLL_INTERVAL_SECONDS = "0"
because i wanted the user of the device to start update manually. Since then i experience that the update takes like 10 minutes longer where all the time is spend after reboot waiting for the server (-> includes logs)
There is a warning about UpdatePollIntervalSeconds is not defined (but it is set to 0).

Aug 06 14:17:34 jetson-tx2 mender[5013]: time="2020-08-06T14:17:34Z" level=error msg="Failed to send status report to server: transient error: reporting status failed: Put dial tcp: lookup on [::1]:53: server misbehaving" module=state
Aug 06 14:17:34 jetson-tx2 mender[5013]: time="2020-08-06T14:17:34Z" level=info msg="State transition: update-commit [ArtifactCommit_Enter] -> update-pre-commit-status-report-retry [ArtifactCommit_Enter]" module=mender
Aug 06 14:17:34 jetson-tx2 mender[5013]: time="2020-08-06T14:17:34Z" level=warning msg="UpdatePollIntervalSeconds is not defined" module=mender

[ 10 minutes]
Aug 06 14:27:34 jetson-tx2 mender[5013]: time="2020-08-06T14:27:34Z" level=info msg="State transition: update-pre-commit-status-report-retry [ArtifactCommit_Enter] -> update-commit [ArtifactCommit_Enter]" module=mender
Successful update       

I get those msg="Failed to send status report to server error every time i deploy an artifact. Also, when i manually run mender send-inventory i don’t have to wait those 10 minutes.

Does anyone know how these things are connected? Is it possibly a bad idea to set the polling interval to 0?

Yeah, I don’t know what would happen with this setting. @lluiscampos do you know?

I think if you just disable the Mender service and then run “mender -check-update” in your code that should accomplish what you are trying to do here.


@genericname Defining it to “0” is the same as not defining it, and the Mender client uses it’s default value which is 30 minutes.

@drewmoseley Both -send-inventory or -check-update require the mender service to be running (i.e. these cli commands just send signals to the service).

I don’t fully understand the use case. But it seems that you can achieve it setting MENDER_UPDATE_POLL_INTERVAL_SECONDS to something very big (one day? one week?) and then let the user manually call mender -check-update as @drewmoseley suggested (but with the service running).

1 Like

Thanks, i wasn’t aware of that. So i will just set the intervall to some high number.

Regarding my other question, about the long update time after reboot until commit, (which i thought might be related) i have to dig a little deeper. Looks like this problem exists only with some of my artifacts.

Yes, I don’t know how could that happen. Report us back if you find out!