Mender demo artifact supporting aarch64 platform

Recently I tried to connect Nvidia Jetson AGX Orin / R34.1.0 to, and this succeeded.

Then I tried to deploy existing “mender-demo-artifact-3.1.0” demo artifact. (by using fake device type “raspberrypi3” )

The download happed but WebUI reported “failed” with following error log.

2022-08-28 21:33:18 +0000 UTC info: Executing script: ArtifactInstall_Leave_50_choose_busybox_arch
2022-08-28 21:33:18 +0000 UTC info: Collected output (stderr) while running script /var/lib/mender/scripts/ArtifactInstall_Leave_50_choose_busybox_arch
No compatible busybox binary for this architecture.

I checked the artifact GitHub and realized that “aarch64” is currently not supported.

So my question is, are there any plan to officially add support for ARM64 / aarch64 platforms, in demo artifact ?


At the moment there are no immediate plans to add aarch64. We have users using Mender on aarch64, but we don’t test it in our CI, and therefore we don’t release binaries for it either. It’s more of a community platform in that sense, and therefore the demo is not available there.

It’s possible this will change in the future as we see growing demand for aarch64, but that’s the status as of today.