Mender convert incorrect partition detection

I’ve tried converting a raw disk image created using dd from a sdcard of a orange-pi running (almost stock) armbian but mender-convert-extract seems to think it’s a single fat32 filesystem:

$ MENDER_ARTIFACT_NAME=convert-1 ./mender-convert    --disk-image input/central.img    --config configs/raspberrypi3_config    --overlay rootfs_overlay_demo/
Running mender-convert-extract: --disk-image input/central.img --config configs/raspberrypi3_config --overlay rootfs_overlay_demo/
2020-01-06 17:04:16 [INFO] [mender-convert-extract] Using configuration file: configs/mender_convert_config
2020-01-06 17:04:16 [INFO] [mender-convert-extract] Using configuration file: configs/raspberrypi3_config
2020-01-06 17:04:16 [INFO] [mender-convert-extract] Validating disk image
2020-01-06 17:04:16 [INFO] [mender-convert-extract] Disk parsed successfully
2020-01-06 17:04:16 [INFO] [mender-convert-extract] NUMBER OF PARTS: 1 TYPE: dos
2020-01-06 17:04:16 [INFO] [mender-convert-extract] PART 1: SIZE: 7,4G TYPE: 0x83
2020-01-06 17:04:16 [INFO] [mender-convert-extract] PART 1: extracting to work/part-1.fs

Tried using both docker and non docker versions of the readme but got the same output.

diskutil output

/dev/disk6 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:     FDisk_partition_scheme                        *8.1 GB     disk6
   1:                      Linux                         7.9 GB     disk6s1

Can you share output of fdisk -l input/central.img? This represents more what the mender-convert tool is looking at.

Makes sense yeah

$ fdisk -l input/central.img                                                                       
Disk input/central.img: 7,52 GiB, 8061452288 bytes, 15745024 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x4f512da8

Device             Boot Start      End  Sectors  Size Id Type
input/central.img1       8192 15430111 15421920  7,4G 83 Linux

Curious if you got it working on orange-pi with Armbian?

What do you mean?

Just wondering if you have any further issues or if everything is working as expected?

Ah, I see. We’ve been trying to get a PoC running with OrangePi Zero since the convert tool doesn’t appear to support extented partitions, and that’s what our armbian install uses.