Mender-convert fails because of unknown arch

I am trying to convert a image of a x86 linux system with mender-convert,
its the second convert that I run. The first try with another linux x86 machine worked well,
I was able to install the result of the deploy folder. But at the second try with another image and the same configuration of mender-convert I get a error message:
2021-03-05 12:01:14 [FATAL] [mender-convert-modify] Unknown arch:

Does anybody of the experts has a Idea what went wrong? The only difference at the second image is, that the disk has been converted from MBR to GPT with UEFI before, to make it fit for mender.

/data/sandbox/mender-convert$ MENDER_ARTIFACT_NAME=release-2021-3-5-A ./docker-mender-convert --disk-image input/mdm-dell-server_20210304-uefi.img --config configs/generic_x86-64_hdd_config
Running mender-convert --disk-image input/mdm-dell-server_20210304-uefi.img --config configs/generic_x86-64_hdd_config
Running mender-convert-extract: --disk-image input/mdm-dell-server_20210304-uefi.img --config configs/generic_x86-64_hdd_config
2021-03-05 11:56:01 [INFO] [mender-convert-extract] Using configuration file: configs/mender_convert_config
2021-03-05 11:56:01 [INFO] [mender-convert-extract] Using configuration file: configs/generic_x86-64_hdd_config
2021-03-05 11:56:01 [INFO] [mender-convert-extract] Validating disk image
2021-03-05 11:56:01 [INFO] [mender-convert-extract] Disk parsed successfully
2021-03-05 11:56:01 [INFO] [mender-convert-extract] NUMBER OF PARTS: 5 TYPE: gpt
2021-03-05 11:56:01 [INFO] [mender-convert-extract] PART 1: SIZE: 15.8G TYPE: 0fc63daf-8483-xxxx-xxxx-3d69d8477de4
2021-03-05 11:56:01 [INFO] [mender-convert-extract] PART 1: extracting to work/part-1.fs
2021-03-05 11:58:57 [INFO] [mender-convert-extract] PART 2: SIZE: 10G TYPE: 0fc63daf-8483-xxxx-xxxx-3d69d8477de4
2021-03-05 11:58:57 [INFO] [mender-convert-extract] PART 2: extracting to work/part-2.fs
2021-03-05 12:00:31 [INFO] [mender-convert-extract] PART 3: SIZE: 15M TYPE: 21686148-xxxx-xxxx-744e-656564454649
2021-03-05 12:00:31 [INFO] [mender-convert-extract] PART 3: extracting to work/part-3.fs
2021-03-05 12:00:31 [INFO] [mender-convert-extract] PART 4: SIZE: 10G TYPE: 0fc63daf-8483-4772-8e79-3d69d8477de4
2021-03-05 12:00:31 [INFO] [mender-convert-extract] PART 4: extracting to work/part-4.fs
2021-03-05 12:01:11 [INFO] [mender-convert-extract] PART 5: SIZE: 512M TYPE: c12a7328-f81f-11d2-ba4b-xxx
2021-03-05 12:01:11 [INFO] [mender-convert-extract] PART 5: extracting to work/part-5.fs
mender-convert-extract has finished. Cleaning up…
Running mender-convert-modify: --disk-image input/mdm-dell-server_20210304-uefi.img --config configs/generic_x86-64_hdd_config
2021-03-05 12:01:13 [INFO] [mender-convert-modify] Using configuration file: configs/mender_convert_config
2021-03-05 12:01:13 [INFO] [mender-convert-modify] Using configuration file: configs/generic_x86-64_hdd_config
2021-03-05 12:01:14 [INFO] [mender-convert-modify] Installing Mender client and related files
2021-03-05 12:01:14 [FATAL] [mender-convert-modify] Sorry, not able to determine target architecture
2021-03-05 12:01:14 [FATAL] [mender-convert-modify] Unknown arch:
mender-convert-modify has finished. Cleaning up…

I suspect our probing just doesn’t handle your image properly. There are 3 functions in modules/ that return that string. I suspect that one of them may need some more logic to properly parse your input image.

We happily accept pull requests so if you find a fix please submit it back.

1 Like

Hi @trailsurfer,

how did you solved your problem?I opened a new ticket with the same error.


Hi, Thank you very much for your Mail.

I had multiple problems with mender-convert.

The „unknown arch“ problem was solved by changing modules/

and make the function returning as “${target_arch}” directly the value target_arch=“x86-64”

probe_arch() {


echo “${target_arch}”


I guess that there was no bug in Mender-convert that caused the problem.

The second problem was regarding the disc partitions sequence.

I solved the problem by changing the sequence of my disc partitions,

The first disk image that I tried to use with mender-convert das the boot partition at partition #4, the linux partition was #2.

I created a new GPT disk with boot partition at #1 and linux partition at #2, gave this to mender-convert, and everything was just fine.

Thanks and best regards for your help,